aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-06 12:35:42 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-06-06 12:35:42 +0000
commit3b99a2c19be326b1630c00dfadced50f2f1b7ecb (patch)
tree7f795296485d460e2f1667c1a01d808a2c75cd3b /community
parentb6a5a824eb16dc5b2889c23f06215bfd6b334ae2 (diff)
downloadaports-3b99a2c19be326b1630c00dfadced50f2f1b7ecb.tar.bz2
aports-3b99a2c19be326b1630c00dfadced50f2f1b7ecb.tar.xz
community/syncthing: fix test on 32 bits arch
backport a patch that fixes tests in 32 bits archs
Diffstat (limited to 'community')
-rw-r--r--community/syncthing/APKBUILD6
-rw-r--r--community/syncthing/correct_block_size_calculation_on_32_bits.patch15
2 files changed, 19 insertions, 2 deletions
diff --git a/community/syncthing/APKBUILD b/community/syncthing/APKBUILD
index aa88cea0b9..b6d62a5f0d 100644
--- a/community/syncthing/APKBUILD
+++ b/community/syncthing/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=syncthing
pkgver=0.14.48
-pkgrel=0
+pkgrel=1
pkgdesc="Open Source Continuous File Synchronization"
url="https://syncthing.net/"
arch="all !armhf"
@@ -18,6 +18,7 @@ subpackages="$pkgname-utils"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
$pkgname.initd
only-test-with-race-when-provided.patch
+ correct_block_size_calculation_on_32_bits.patch
"
builddir="$srcdir/src/github.com/$pkgname/$pkgname"
@@ -58,4 +59,5 @@ utils() {
sha512sums="a779ae6b25ca0b47536bdf7ed968a18e1ba294c67b1a8e75f98a112ce470853cc5d0147fdad8420d2595f983b1457f16cd642e0a1bc1a1b16d8c5672c2f1fa6a syncthing-0.14.48.tar.gz
7fe49210180827c28f3ee9a1a95da3884dbef34de9bdc643f4455c9a056adba81f16c1c6ac059e83bee360aea091ace98b8a6f4c4b26a32c450f61f15206d3f5 syncthing.initd
-3fd2b699e07891ae16c67af56d516ba0fde13d5e5d067dd680fc59f9fc5b2f7c5f685b040841588cca6de1f7fb4b094572e5eb73dda8ab30d4b2994d3f526047 only-test-with-race-when-provided.patch"
+3fd2b699e07891ae16c67af56d516ba0fde13d5e5d067dd680fc59f9fc5b2f7c5f685b040841588cca6de1f7fb4b094572e5eb73dda8ab30d4b2994d3f526047 only-test-with-race-when-provided.patch
+d4ef3ca7cc4f1e14c1127b16fd3a00913ed9a20bbf0a1caf4aa79a96edc4c3d7b80fc256e409bb2d920d3239b64777c9e97455a9b3b22a07661c7bd91619fa13 correct_block_size_calculation_on_32_bits.patch"
diff --git a/community/syncthing/correct_block_size_calculation_on_32_bits.patch b/community/syncthing/correct_block_size_calculation_on_32_bits.patch
new file mode 100644
index 0000000000..db0e898817
--- /dev/null
+++ b/community/syncthing/correct_block_size_calculation_on_32_bits.patch
@@ -0,0 +1,15 @@
+--- a/lib/protocol/protocol.go
++++ b/lib/protocol/protocol.go
+Author: Jakob Borg <jakob@kastelo.net>
+Date: Wed Jun 6 09:59:33 2018 +0200
+
+ lib/protocol: Correct block size calculation on 32 bit archs (fixes #4990) (#4991)
+@@ -54,7 +54,7 @@
+ func BlockSize(fileSize int64) int {
+ var blockSize int
+ for _, blockSize = range BlockSizes {
+- if fileSize < int64(DesiredPerFileBlocks*blockSize) {
++ if fileSize < DesiredPerFileBlocks*int64(blockSize) {
+ break
+ }
+ }