aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-10-06 14:10:10 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-10-06 18:20:34 +0200
commit5ce3bb52faf9485504586c4a946fbebb2828f3a5 (patch)
tree5cb7f2c7e84dc81f9c1531a99aae7e59496da3bc /community
parent027895d15121429f152c4754d63f04d3c574851f (diff)
downloadaports-5ce3bb52faf9485504586c4a946fbebb2828f3a5.tar.bz2
aports-5ce3bb52faf9485504586c4a946fbebb2828f3a5.tar.xz
community/cloc: upgrade to 1.80
Diffstat (limited to 'community')
-rw-r--r--community/cloc/APKBUILD10
-rw-r--r--community/cloc/disable-01_opts.patch14
-rw-r--r--community/cloc/disable-git-tests.patch15
3 files changed, 20 insertions, 19 deletions
diff --git a/community/cloc/APKBUILD b/community/cloc/APKBUILD
index bfd9845dd6..4abed10dac 100644
--- a/community/cloc/APKBUILD
+++ b/community/cloc/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=cloc
-pkgver=1.78
+pkgver=1.80
pkgrel=0
pkgdesc="Count lines of code"
url="https://github.com/AlDanial/cloc"
@@ -11,8 +11,8 @@ depends="perl perl-algorithm-diff perl-regexp-common
perl-parallel-forkmanager"
makedepends=""
subpackages="$pkgname-doc"
-source="https://github.com/AlDanial/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
- disable-01_opts.patch"
+source="https://github.com/AlDanial/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
+ disable-git-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -32,5 +32,5 @@ package() {
"$pkgdir"/usr/share/doc/$pkgname/
}
-sha512sums="e5824d0a0796302173974e516848abdb4e653c1df4d660bf60b51e766ad09239b8b72276e2cb6b57771399dadfd1c7eb60218dc62b80cebdeebf607150baeb35 cloc-1.78.tar.gz
-10039c23d06f16f3c44427ee0f0e5d16dd05d2c5364145f57c1e5de94227387907f9ecebe7d42fc976599a8c1814e51d5f0a4eddef154222c5138cbcce777c4a disable-01_opts.patch"
+sha512sums="3f41a0e2bd4becbb393e24834c45d9998217443d5c6d0478be5ce4f9506bb8dcb44088ce4a2c75c06cb6af47b4432f3dc58db9009f9a350a00dd80802109117f cloc-1.80.tar.gz
+57c645db88bd83a06c32a38311b5f5a8cb0b86af454f20c7f4ce4311cc87932f8a61de381d5ca9f7189271034b487f2cb35f1d8568674f772d2969fb2e4e9cac disable-git-tests.patch"
diff --git a/community/cloc/disable-01_opts.patch b/community/cloc/disable-01_opts.patch
deleted file mode 100644
index 4f4303627e..0000000000
--- a/community/cloc/disable-01_opts.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-This part of the test suite currently fails, we therefore temporarily
-disable it until we figured out what's causing the failure.
-
-diff -upr cloc-1.76.orig/Unix/Makefile cloc-1.76/Unix/Makefile
---- cloc-1.76.orig/Unix/Makefile 2018-02-10 17:51:48.335889390 +0100
-+++ cloc-1.76/Unix/Makefile 2018-02-10 17:52:02.309227510 +0100
-@@ -95,7 +95,6 @@ test-pod:
- # Rule: test-code - Check that the counter works
- test-code:
- t/00_C.t
-- t/01_opts.t
-
- # Rule: test - Run tests
- test: test-perl test-pod test-code
diff --git a/community/cloc/disable-git-tests.patch b/community/cloc/disable-git-tests.patch
new file mode 100644
index 0000000000..b41f12a384
--- /dev/null
+++ b/community/cloc/disable-git-tests.patch
@@ -0,0 +1,15 @@
+Disable all git-related tests. Those probably fail because the source
+tarball doesn't ship the `.git` directory. Needs further investigation.
+
+diff -upr cloc-1.80.orig/Unix/Makefile cloc-1.80/Unix/Makefile
+--- cloc-1.80.orig/Unix/Makefile 2018-10-06 18:14:59.066930304 +0200
++++ cloc-1.80/Unix/Makefile 2018-10-06 18:15:06.760329821 +0200
+@@ -95,8 +95,6 @@ test-pod:
+ # Rule: test-code - Check that the counter works
+ test-code:
+ t/00_C.t
+- t/02_git.t
+- t/01_opts.t
+
+ # Rule: test - Run tests
+ test: test-perl test-pod test-code