aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-10-03 19:27:30 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-10-09 06:35:28 +0000
commit712a99e25461ae27bd9674f8870fd7abefc6013d (patch)
tree6566130270e68b446b0aae3a972c95602352f060 /community
parent3be855a9170213861cb95bc2b884957869ff66d5 (diff)
downloadaports-712a99e25461ae27bd9674f8870fd7abefc6013d.tar.bz2
aports-712a99e25461ae27bd9674f8870fd7abefc6013d.tar.xz
community/scapy: updated APKBUILD, added check()
Diffstat (limited to 'community')
-rw-r--r--community/scapy/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/scapy/APKBUILD b/community/scapy/APKBUILD
index cc748014ab..da5bdfc405 100644
--- a/community/scapy/APKBUILD
+++ b/community/scapy/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=scapy
pkgver=2.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="Powerful interactive packet manipulation"
url="http://www.secdev.org/projects/scapy/"
arch="noarch"
@@ -17,12 +17,17 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
+ python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
}
package() {
cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="3b267739fbd4e1c5719f58be0f76a373085b5f3b34ab3e410e7f23614745d90f425c6226f0e5f73429c81582f58ee43f4cc3ec2868c7fe1600c14e4f81142df7 scapy-2.4.0.zip"