aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-11 16:36:28 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-11 16:37:57 +0200
commit7662bc3e73b9b9564888c16b52c19510deae62d2 (patch)
tree7ddcc848f186ccdecafe028e9dfa65431d39d976 /community
parent0f74bcda4e8541d898217d53aaba0b19f2010d03 (diff)
downloadaports-7662bc3e73b9b9564888c16b52c19510deae62d2.tar.bz2
aports-7662bc3e73b9b9564888c16b52c19510deae62d2.tar.xz
community/tinyssh: fix #9550
only run tinysshd-keygen if /etc/tinyssh/sshkeys is missing
Diffstat (limited to 'community')
-rw-r--r--community/tinyssh/APKBUILD4
-rw-r--r--community/tinyssh/tinyssh.initd6
2 files changed, 6 insertions, 4 deletions
diff --git a/community/tinyssh/APKBUILD b/community/tinyssh/APKBUILD
index 341699a4eb..747660ac0f 100644
--- a/community/tinyssh/APKBUILD
+++ b/community/tinyssh/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=tinyssh
pkgver=20180201
-pkgrel=1
+pkgrel=2
pkgdesc="Small SSH server using NaCl / TweetNaCl (no dependency on OpenSSL)"
url="https://tinyssh.org/"
arch="all"
@@ -65,5 +65,5 @@ openrc() {
}
sha512sums="fa0e0245168fc0549fa6db807106e0b3c51be479498de6bb4ced714e2bb156613447333ed034e00d8c24dd79411f632174f0d8f5b1cf2f1d26c77dd5515971e8 tinyssh-20180201.tar.gz
-99ed9a43bf92db8318c001d287ebf52f36f377ddcd6702cfc9e1331435834ce4a0c5804fafbdeaf9beadd5c8ac828d17cedd19128c74f7bfe737b129b57e196b tinyssh.initd
+22140d281d5017ea07b819b25ff11814c2edcd6eb09a126f9ad325fae38117531ab5136296023df07ecd036adfaf664b4434e1bb215b9f628bc95dd1873c03fa tinyssh.initd
7c6282a6ae972d83d3e624530cac4958adee1e2313d0e44aff38c94bde1a3f549a536ec80e594d44c29a6a981919dd30322e8d8511626fdb6493c98587047392 tinyssh.confd"
diff --git a/community/tinyssh/tinyssh.initd b/community/tinyssh/tinyssh.initd
index 49225d2fce..522250282a 100644
--- a/community/tinyssh/tinyssh.initd
+++ b/community/tinyssh/tinyssh.initd
@@ -28,6 +28,8 @@ depend() {
}
start_pre() {
- checkpath --directory ${CONFDIR}
- $keygen $keydir 2>/dev/null
+ if ! [ -d "$keydir" ]; then
+ checkpath --directory ${CONFDIR}
+ $keygen $keydir 2>/dev/null
+ fi
}