aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-08 10:23:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-08 10:24:05 +0000
commit7d5d150977816ad474da9e36cc5975c15d74ec81 (patch)
treed2439e4b3f2f4e0b55840babca85b84c571e5f0e /community
parent2103efcf25f1ef29921454f1fb1094ed3f86c33a (diff)
downloadaports-7d5d150977816ad474da9e36cc5975c15d74ec81.tar.bz2
aports-7d5d150977816ad474da9e36cc5975c15d74ec81.tar.xz
community/lua-busted: upgrade to 2.0_rc13
Diffstat (limited to 'community')
-rw-r--r--community/lua-busted/APKBUILD10
-rw-r--r--community/lua-busted/fix-tests.patch92
2 files changed, 4 insertions, 98 deletions
diff --git a/community/lua-busted/APKBUILD b/community/lua-busted/APKBUILD
index e757ef3dc4..094fcfd2e5 100644
--- a/community/lua-busted/APKBUILD
+++ b/community/lua-busted/APKBUILD
@@ -2,9 +2,9 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lua-busted
_pkgname=busted
-pkgver=2.0_rc12
-_pkgver=${pkgver/_/.}-1
-pkgrel=4
+pkgver=2.0_rc13
+_pkgver=${pkgver/_/.}-0
+pkgrel=0
pkgdesc="Elegant Lua unit testing"
url="https://olivinelabs.com/busted/"
arch="noarch"
@@ -15,7 +15,6 @@ depends="lua-cliargs lua-filesystem lua-system lua-cjson lua-say
checkdepends=""
subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/Olivine-Labs/$_pkgname/archive/v$_pkgver.tar.gz
- fix-tests.patch
use-cjson.patch"
builddir="$srcdir/$_pkgname-$_pkgver"
# tests fail on x86_64 because cl_standalone.lua output is different, i don't know why --kaniini
@@ -87,6 +86,5 @@ _subpackage() {
install -m 755 -D bin/busted-$lver "$subpkgdir"/usr/bin/busted-$lver
}
-sha512sums="0cb1f6a66110514dc3675b2e667cca676e6672e895b57ffba438e89a1e0a7f4f8f941cab54ead905758987be15e9885e1eeb82baabc9d18bf29ea56b832b89b1 lua-busted-2.0_rc12.tar.gz
-c4ec5de43d76da18a7c723744d2930fc78224fe151fd80c141dbb08dce9f10ee94335684a794ad35c902285f40234899e0b12d1995825cb3d250c29ed82bdeec fix-tests.patch
+sha512sums="ac6d6c96c6782184cf79cbd41d213974aa6bc50908fe77e1b0a874c1b82cd9a9300e05a8897489d2f5a8cb5f68ae2da24db9d10b0e0244d364f781606eb72d9f lua-busted-2.0_rc13.tar.gz
6de3c1181a391956f6ea01994960a5de3292a377be1949556eb6cd11986267e3da707decef1838f42f0236af4b25ce4ce09217abe976caa0110840b69efcab43 use-cjson.patch"
diff --git a/community/lua-busted/fix-tests.patch b/community/lua-busted/fix-tests.patch
deleted file mode 100644
index 365c9c48ce..0000000000
--- a/community/lua-busted/fix-tests.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-From ed3f70805ac0e30bf14f6a5850e873329f5e337c Mon Sep 17 00:00:00 2001
-From: Oscar Lim <olim@ucla.edu>
-Date: Mon, 29 Aug 2016 11:54:59 -0700
-Subject: [PATCH] Fix failing tests after penlight upgrade
-
-This fixes failing unit tests after upgrading `penlight`. Apparently,
-the new version of `penlight` uses `pl.List` internally when traversing
-a directory. Hence, we cannot use `pl.List` in any of the insulation
-tests.
-
-Alpine notes:
- This patch is backported from upstream.
----
- spec/insulate-expose_spec.lua | 24 ++++++++++++------------
- 1 file changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/spec/insulate-expose_spec.lua b/spec/insulate-expose_spec.lua
-index 0409a3d..bba84bd 100644
---- a/spec/insulate-expose_spec.lua
-+++ b/spec/insulate-expose_spec.lua
-@@ -13,9 +13,9 @@ describe('Tests insulation', function()
-
- it('updates package.loaded', function()
- assert.is_not_nil(pl)
-- assert.is_not_nil(List)
-+ assert.is_not_nil(Date)
- assert.is_not_nil(package.loaded.pl)
-- assert.is_not_nil(package.loaded['pl.List'])
-+ assert.is_not_nil(package.loaded['pl.Date'])
- end)
- end)
-
-@@ -27,9 +27,9 @@ describe('Tests insulation', function()
-
- it('restores package.loaded', function()
- assert.is_nil(pl)
-- assert.is_nil(List)
-+ assert.is_nil(Date)
- assert.is_nil(package.loaded.pl)
-- assert.is_nil(package.loaded['pl.List'])
-+ assert.is_nil(package.loaded['pl.Date'])
- end)
- end)
- end)
-@@ -54,9 +54,9 @@ insulate('', function()
-
- it('updates package.loaded', function()
- assert.is_not_nil(pl)
-- assert.is_not_nil(List)
-+ assert.is_not_nil(Date)
- assert.is_not_nil(package.loaded.pl)
-- assert.is_not_nil(package.loaded['pl.List'])
-+ assert.is_not_nil(package.loaded['pl.Date'])
- end)
- end)
- end)
-@@ -74,9 +74,9 @@ insulate('', function()
-
- it('does not restore package.loaded', function()
- assert.is_not_nil(pl)
-- assert.is_not_nil(List)
-+ assert.is_not_nil(Date)
- assert.is_not_nil(package.loaded.pl)
-- assert.is_not_nil(package.loaded['pl.List'])
-+ assert.is_not_nil(package.loaded['pl.Date'])
- end)
- end)
- end)
-@@ -93,9 +93,9 @@ insulate('', function()
- end)
-
- it('Tests package.loaded persists without insulate', function()
-- assert.is_not_nil(List)
-+ assert.is_not_nil(Date)
- assert.is_not_nil(package.loaded.pl)
-- assert.is_not_nil(package.loaded['pl.List'])
-+ assert.is_not_nil(package.loaded['pl.Date'])
- end)
- end)
-
-@@ -107,9 +107,9 @@ describe('Tests after insulating an expose block', function()
-
- it('restores package.loaded', function()
- assert.is_nil(pl)
-- assert.is_nil(List)
-+ assert.is_nil(Date)
- assert.is_nil(package.loaded.pl)
-- assert.is_nil(package.loaded['pl.List'])
-+ assert.is_nil(package.loaded['pl.Date'])
- end)
- end)
-