aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-26 22:32:37 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-27 15:30:37 +0200
commit8cd6917e388ff56599747cf3ae30bea40ffe0fe3 (patch)
tree0a97bd2a7f2d60c7027e190a31692ba8c1cb735a /community
parent206957b0ed543128ee91fff31747561be1dd38c1 (diff)
downloadaports-8cd6917e388ff56599747cf3ae30bea40ffe0fe3.tar.bz2
aports-8cd6917e388ff56599747cf3ae30bea40ffe0fe3.tar.xz
community/roundcubemail: fix scripts in bin/
Diffstat (limited to 'community')
-rw-r--r--community/roundcubemail/APKBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/community/roundcubemail/APKBUILD b/community/roundcubemail/APKBUILD
index 540f486abd..1be6db4f16 100644
--- a/community/roundcubemail/APKBUILD
+++ b/community/roundcubemail/APKBUILD
@@ -62,8 +62,6 @@ prepare() {
cd "$builddir"
default_prepare
- # fix permissions
- find . -type f -print | xargs chmod a-x
# remove .htaccess
find . -name \.htaccess -print | xargs rm -f
@@ -73,6 +71,20 @@ prepare() {
# Useless 'cause there's no FOSS PDO driver.
rm -R SQL/oracle*
+
+ cd bin
+
+ # Remove development scripts.
+ rm -f cssshrink.* dumpschema.* install-jsdeps.* installto.* \
+ jsshrink.* makedoc.*
+
+ # These are all PHP files, not shell scripts!
+ local file; for file in *.sh; do
+ mv $file ${file%.sh}.php
+ done
+
+ # Fix shebang.
+ sed -i "s|/usr/bin/env php|/usr/bin/env $_php|" *.php
}
package() {