aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-30 14:38:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-30 16:03:32 +0000
commita8290ba5c43b4677378a357497bf01856f145921 (patch)
treefcc7780a22fbbb09034a59e8f25feac16b1c4f95 /community
parent2ecdfad56d19496fdc2bf7d1ae60b91b1445f011 (diff)
downloadaports-a8290ba5c43b4677378a357497bf01856f145921.tar.bz2
aports-a8290ba5c43b4677378a357497bf01856f145921.tar.xz
community/greybird-themes: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/greybird-themes/APKBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/community/greybird-themes/APKBUILD b/community/greybird-themes/APKBUILD
new file mode 100644
index 0000000000..a8d91c85fd
--- /dev/null
+++ b/community/greybird-themes/APKBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=greybird-themes
+pkgver=3.22.8
+pkgrel=0
+pkgdesc="A clean minimalistic theme for Xfce, GTK+ 2 and 3"
+url="http://shimmerproject.org/project/greybird/"
+arch="noarch"
+license="GPL-2.0-or-later CC-BY-SA-3.0"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-gtk2 $pkgname-gtk3 $pkgname-metacity $pkgname-xfwm4
+ $pkgname-xfce4-notifyd:_notify $pkgname-unity"
+source="greybird-$pkgver.tar.gz::https://github.com/shimmerproject/Greybird/archive/v$pkgver.tar.gz
+ "
+
+builddir="$srcdir"/Greybird-$pkgver
+build() {
+ cd "$_builddir"
+ # Cleanup
+ # Remove Unity theme
+ rm -f gtk-3.0/apps/unity.css
+ rm -f gtk-3.0/apps/lightdm-unity-greeter.css
+
+ sed -i '/unity\.css/d' gtk-3.0/gtk.css
+ sed -i '/lightdm-unity-greeter\.css/d' gtk-3.0/gtk.css
+ sed -i '/lightdm-gtk-greeter\.css/d' gtk-3.0/gtk.css
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/share/themes/Greybird
+ cp -pr * "$pkgdir"/usr/share/themes/Greybird
+}
+
+_mv() {
+ pkgdesc="$1"
+ install_if="$pkgname=$pkgver-r$pkgrel $2";
+ depends=
+ local _i
+ shift; shift
+ mkdir -p "$subpkgdir"/usr/share/themes/Greybird
+ for _i; do
+ msg "moving $_i"
+ mv "$pkgdir"/usr/share/themes/Greybird/$_i \
+ "$subpkgdir"/usr/share/themes/Greybird || return 1
+ done
+}
+
+
+gtk2() {
+ _mv "Greybird GTK+2 themes" gtk+2.0 gtk-2.0
+ depends="gtk-murrine-engine"
+}
+
+gtk3() { _mv "Greybird GTK+3 themes" gtk+3.0 gtk-3.0; }
+metacity() { _mv "Greybird Metacity themes" metacity metacity-1; }
+xfwm4() { _mv "Greybird Xfce4 themes" xfwm4 xfwm4 'xfwm4-*'; }
+_notify() { _mv "Greybird Xfce4-notifyd themes" xfce4-notifyd 'xfce-notify-*'; }
+unity() { _mv "Greybird Unity themes" unity 'unity'; }
+
+sha512sums="c6ac0dafc926ec2a0b01b4d44f602e533f97f806be32096208c08461502cadcda3f1e63012ad78ffaaa9c791c5af72ce2b7e0578b1f7c0d3ab407763bc40f94b greybird-3.22.8.tar.gz"