aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-04 10:05:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-04 10:06:49 +0000
commitc32d581adbe51f0cd6c208e19d4686e8ace86fba (patch)
tree8690c008a8c7d55d0a548773c7c395df71e778ef /community
parent6a932218e91a681e86d03733d271ecdfc031df20 (diff)
downloadaports-c32d581adbe51f0cd6c208e19d4686e8ace86fba.tar.bz2
aports-c32d581adbe51f0cd6c208e19d4686e8ace86fba.tar.xz
community/cloudi: fix detection of erlang
Fixes build on aarch64. Reported upstream: https://github.com/CloudI/CloudI/issues/216
Diffstat (limited to 'community')
-rw-r--r--community/cloudi/0001-Fix-autoconf-Erlang-version-check.patch28
-rw-r--r--community/cloudi/APKBUILD4
2 files changed, 31 insertions, 1 deletions
diff --git a/community/cloudi/0001-Fix-autoconf-Erlang-version-check.patch b/community/cloudi/0001-Fix-autoconf-Erlang-version-check.patch
new file mode 100644
index 0000000000..e6c4eeb4b4
--- /dev/null
+++ b/community/cloudi/0001-Fix-autoconf-Erlang-version-check.patch
@@ -0,0 +1,28 @@
+From 99de8509dad80e44d2e78a2e5c38ad8ce40b9c65 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 4 Oct 2018 11:32:27 +0200
+Subject: [PATCH] Fix autoconf Erlang version check
+
+Prevent the $- variable to be expanded in shell.
+
+Fixes #216
+---
+ src/m4/ax_erlang_otp_version.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/m4/ax_erlang_otp_version.m4 b/src/m4/ax_erlang_otp_version.m4
+index 94923837..e6b38873 100644
+--- a/src/m4/ax_erlang_otp_version.m4
++++ b/m4/ax_erlang_otp_version.m4
+@@ -168,7 +168,7 @@ AC_DEFUN([AX_ERLANG_REQUIRE_OTP_VER],
+ true ->
+ %% Remove -1 from R16B03-1
+ list_to_integer(lists:takewhile(fun(C) ->
+- C /= $-
++ C /= \$-
+ end, MinorT))
+ end,
+ if
+--
+2.19.0
+
diff --git a/community/cloudi/APKBUILD b/community/cloudi/APKBUILD
index 7a14065db0..1f112345c6 100644
--- a/community/cloudi/APKBUILD
+++ b/community/cloudi/APKBUILD
@@ -29,7 +29,7 @@
pkgname=cloudi
pkgver=1.7.4
-pkgrel=0
+pkgrel=1
pkgdesc="Cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
url="https://cloudi.org/"
license="MIT"
@@ -75,6 +75,7 @@ install=""
subpackages=""
source="https://osdn.net/dl/$pkgname/$pkgname-$pkgver.tar.gz
0005-Disable-tests-for-aports-buildservers.patch
+ 0001-Fix-autoconf-Erlang-version-check.patch
$pkgname.initd"
builddir="$srcdir/cloudi-$pkgver/src"
@@ -134,4 +135,5 @@ package() {
sha512sums="4215b47a696eb89dbba32f3b607e2cec756635544f6d80ddcd87c783f881b403a5700701a3c11df14f67bb1cca5af88830a144630fc1206dbe06285c7dc13f1a cloudi-1.7.4.tar.gz
b2ef0cf07e207cbe62a34edb69ac4700bd5a75d9924e6597595e69f0988772d833d6af882cfa40278c9efe4b042da2952f9b7276b3c80c4b015b0c1490782b59 0005-Disable-tests-for-aports-buildservers.patch
+c57ae763f4a5aa29b24bf92e255414de2e22a6b8114b322096be8e59c3af725a8b94802efb11c7c67945c46920183e454c6c55103004c3a0b9e8727f82307b17 0001-Fix-autoconf-Erlang-version-check.patch
053f860f656617012208a0e1909e43b2f8979d381a90d3fa5a745a9cf5021fe54556a641fef2badaa9955f2394d00e32183389cb9b501169dcbf8cbe4fbb0329 cloudi.initd"