aboutsummaryrefslogtreecommitdiffstats
path: root/main/augeas
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-11 14:38:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-11 14:38:23 +0000
commit32fd5ec6c93e4464c4140e08b3482d8f7b309661 (patch)
treec6cd14ee74b2487b48821d7e1482251a2993aa73 /main/augeas
parenta04874ab618720cc7c47cb94804eaa00bcbb0d75 (diff)
downloadaports-32fd5ec6c93e4464c4140e08b3482d8f7b309661.tar.bz2
aports-32fd5ec6c93e4464c4140e08b3482d8f7b309661.tar.xz
main/augeas: fix pkg-config file
fixes fatal error: libxml/tree.h: No such file or directory
Diffstat (limited to 'main/augeas')
-rw-r--r--main/augeas/APKBUILD9
-rw-r--r--main/augeas/augeas-requires-libxml2.patch20
2 files changed, 26 insertions, 3 deletions
diff --git a/main/augeas/APKBUILD b/main/augeas/APKBUILD
index 39b481211d..00d41f38de 100644
--- a/main/augeas/APKBUILD
+++ b/main/augeas/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=augeas
pkgver=0.10.0
-pkgrel=0
+pkgrel=1
pkgdesc="a configuration editing tool"
url="http://augeas.net"
arch="all"
@@ -11,7 +11,9 @@ makedepends="readline-dev libxml2-dev"
install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-tests"
source="http://augeas.net/download/augeas-$pkgver.tar.gz
- regexp.c.patch"
+ regexp.c.patch
+ augeas-requires-libxml2.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -45,4 +47,5 @@ tests() {
"$subpkgdir"/usr/share/augeas/lenses/dist/
}
md5sums="fe1834e90a066c3208ac0214622c7352 augeas-0.10.0.tar.gz
-a9f0fe2cd7e6aebf916747207cc2b537 regexp.c.patch"
+a9f0fe2cd7e6aebf916747207cc2b537 regexp.c.patch
+ea212ab45cde19301646b974cc0941e8 augeas-requires-libxml2.patch"
diff --git a/main/augeas/augeas-requires-libxml2.patch b/main/augeas/augeas-requires-libxml2.patch
new file mode 100644
index 0000000000..64e45695dc
--- /dev/null
+++ b/main/augeas/augeas-requires-libxml2.patch
@@ -0,0 +1,20 @@
+From 11b00ad49301ae6e246eae3e5ee64a80e2084a43 Mon Sep 17 00:00:00 2001
+From: Richard W.M. Jones <rjones@redhat.com>
+Date: Sat, 03 Dec 2011 14:21:50 +0000
+Subject: pkg-config: Augeas requires libxml2.
+
+---
+diff --git a/augeas.pc.in b/augeas.pc.in
+index c97847d..9e166db 100644
+--- a/augeas.pc.in
++++ b/augeas.pc.in
+@@ -6,6 +6,6 @@ includedir=@includedir@
+ Name: augeas
+ Version: @VERSION@
+ Description: Augeas configuration editing library
+-Requires:
++Requires.private: libxml-2.0
+ Libs: -L${libdir} -laugeas @LIBS@
+ Cflags: -I${includedir}
+--
+cgit v0.9.0.2