aboutsummaryrefslogtreecommitdiffstats
path: root/main/axel
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-02-06 18:15:09 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-02-06 18:45:14 +0000
commit1621cee01b6111d262e6478cc59c4dcdac13460e (patch)
treeb52cbb66b316dfd3ae82634608a7f4074eb41164 /main/axel
parentf4f7e6c25c901d7b5424a71918115b3b0c112e15 (diff)
downloadaports-1621cee01b6111d262e6478cc59c4dcdac13460e.tar.bz2
aports-1621cee01b6111d262e6478cc59c4dcdac13460e.tar.xz
main/axel: modernize and add simple check
Add a simple test as upstream doesn't provide a test suite.
Diffstat (limited to 'main/axel')
-rw-r--r--main/axel/APKBUILD35
1 files changed, 13 insertions, 22 deletions
diff --git a/main/axel/APKBUILD b/main/axel/APKBUILD
index 459f3be466..17f2b3fe80 100644
--- a/main/axel/APKBUILD
+++ b/main/axel/APKBUILD
@@ -2,45 +2,36 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=axel
pkgver=2.4
-pkgrel=1
+pkgrel=2
pkgdesc="A multiple-connection concurrent downloader"
url="http://axel.alioth.debian.org/"
arch="all"
license="GPL-2.0-or-later"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
subpackages="$pkgname-doc"
-source="http://dev.alpinelinux.org/archive/axel/axel-$pkgver.tar.gz"
+source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/axel-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--etcdir=/etc \
--mandir=/usr/share/man \
- --i18n=0 \
- || return 1
- make || return 1
+ --i18n=0
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./axel --help > /dev/null
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="5cd8e63e325da6fe44ec213a2464e98dc68f9d43fe4b7200f5893b91b42fc1737b5e8d17709ee6d0d23cc74b68ab72f9f264b4bd941358b260f745ed6706d959 axel-2.4.tar.gz"