aboutsummaryrefslogtreecommitdiffstats
path: root/main/bind
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-02 19:52:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:20 +0000
commit786e56cd1d9c5dbf95e539a900e486b25673fade (patch)
treedf1d2265801cbd085cb5f8a36b679aca226fe015 /main/bind
parentf3aadb99a97ccd4e6d82669140d182aea121133e (diff)
downloadaports-786e56cd1d9c5dbf95e539a900e486b25673fade.tar.bz2
aports-786e56cd1d9c5dbf95e539a900e486b25673fade.tar.xz
main/bind: rebuild against libressl-2.7
Diffstat (limited to 'main/bind')
-rw-r--r--main/bind/APKBUILD9
-rw-r--r--main/bind/bind.so_bsdcompat.patch4
-rw-r--r--main/bind/libressl-2.7.patch52
3 files changed, 59 insertions, 6 deletions
diff --git a/main/bind/APKBUILD b/main/bind/APKBUILD
index 2458b66a58..c933c10e83 100644
--- a/main/bind/APKBUILD
+++ b/main/bind/APKBUILD
@@ -8,7 +8,7 @@ _ver=${pkgver%_p*}
_p=${pkgver#*_p}
_major=${pkgver%%.*}
[ "$_p" != "$pkgver" ] && _ver="${_ver}-P$_p"
-pkgrel=0
+pkgrel=1
pkgdesc="The ISC DNS server"
url="http://www.isc.org"
arch="all"
@@ -24,6 +24,7 @@ install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs $pkgname-openrc $pkgname-tools"
source="https://ftp.isc.org/isc/${pkgname}${_major}/$_ver/$pkgname-$_ver.tar.gz
bind.so_bsdcompat.patch
+ libressl-2.7.patch
named.initd
named.confd
named.conf.authoritative
@@ -47,6 +48,7 @@ builddir="$srcdir/$pkgname-$_ver"
# - CVE-2016-9444
prepare() {
+ default_prepare
cd "$builddir"
### http://bugs.gentoo.org/show_bug.cgi?id=227333
@@ -60,8 +62,6 @@ prepare() {
-e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
"${i}"
done
-
- patch -p0 -i "$srcdir"/bind.so_bsdcompat.patch
}
build() {
@@ -137,7 +137,8 @@ tools() {
}
sha512sums="4b6f1b8830f57cdffcbd3c4cfb965b978d8c6e99fa40aae8276ea2741ef47d336e1edf8fb33a01a8a5d7e0efd910adae7645152e948c5728f08fa103b2b230f3 bind-9.12.0.tar.gz
-f3e3d1b680617485b9db20a59a10fec3b3b539d423984493228a7d5aaa29d699b9012ad60e863e56bdaf15b73952c22710d0ded1c86cd24417ac775ee062cfa3 bind.so_bsdcompat.patch
+7167dccdb2833643dfdb92994373d2cc087e52ba23b51bd68bd322ff9aca6744f01fa9d8a4b9cd8c4ce471755a85c03ec956ec0d8a1d4fae02124ddbed6841f6 bind.so_bsdcompat.patch
+70cc46b8ecc863b8dfb9b36648131963f40377c5586c6e6ea469f0b7a4a7b3f6e78ad4e7cb21fabc9660b2a02ddc0677d33fc32e8b6948b37b74119cc7de68b0 libressl-2.7.patch
196c0a3b43cf89e8e3547d7fb63a93ff9a3306505658dfd9aa78e6861be6b226580b424dd3dd44b955b2d9f682b1dc62c457f3ac29ce86200ef070140608c015 named.initd
127bdcc0b5079961f0951344bc3fad547450c81aee2149eac8c41a8c0c973ea0ffe3f956684c6fcb735a29c43d2ff48c153b6a71a0f15757819a72c492488ddf named.confd
d2f61d02d7829af51faf14fbe2bafe8bc90087e6b6697c6275a269ebbddcaa14a234fff5c41da793e945e8ff1de3de0858a40334e0d24289eab98df4bb721ac5 named.conf.authoritative
diff --git a/main/bind/bind.so_bsdcompat.patch b/main/bind/bind.so_bsdcompat.patch
index 83120f77de..69751e13b3 100644
--- a/main/bind/bind.so_bsdcompat.patch
+++ b/main/bind/bind.so_bsdcompat.patch
@@ -1,5 +1,5 @@
---- lib/isc/unix/socket.c.orig 2005-11-03 17:08:42.000000000 -0600
-+++ lib/isc/unix/socket.c 2006-02-18 13:09:15.000000000 -0600
+--- a/lib/isc/unix/socket.c.orig 2005-11-03 17:08:42.000000000 -0600
++++ b/lib/isc/unix/socket.c 2006-02-18 13:09:15.000000000 -0600
@@ -245,6 +245,8 @@
#define SOCK_DEAD(s) ((s)->references == 0)
diff --git a/main/bind/libressl-2.7.patch b/main/bind/libressl-2.7.patch
new file mode 100644
index 0000000000..6f3b331297
--- /dev/null
+++ b/main/bind/libressl-2.7.patch
@@ -0,0 +1,52 @@
+diff --git a/lib/dns/openssldh_link.c b/lib/dns/openssldh_link.c
+index ab2f68a..727d5dd 100644
+--- a/lib/dns/openssldh_link.c
++++ b/lib/dns/openssldh_link.c
+@@ -69,7 +69,7 @@ static isc_result_t openssldh_todns(const dst_key_t *key, isc_buffer_t *data);
+
+ static BIGNUM *bn2, *bn768, *bn1024, *bn1536;
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ /*
+ * DH_get0_key, DH_set0_key, DH_get0_pqg and DH_set0_pqg
+ * are from OpenSSL 1.1.0.
+diff --git a/lib/dns/openssldsa_link.c b/lib/dns/openssldsa_link.c
+index 4c2d3e4..5e8096f 100644
+--- a/lib/dns/openssldsa_link.c
++++ b/lib/dns/openssldsa_link.c
+@@ -49,7 +49,7 @@
+
+ static isc_result_t openssldsa_todns(const dst_key_t *key, isc_buffer_t *data);
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ static void
+ DSA_get0_pqg(const DSA *d, const BIGNUM **p, const BIGNUM **q,
+ const BIGNUM **g)
+diff --git a/lib/dns/opensslecdsa_link.c b/lib/dns/opensslecdsa_link.c
+index 9168ec2..a39dadf 100644
+--- a/lib/dns/opensslecdsa_link.c
++++ b/lib/dns/opensslecdsa_link.c
+@@ -42,7 +42,7 @@
+
+ #define DST_RET(a) {ret = a; goto err;}
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ /* From OpenSSL 1.1 */
+ static void
+ ECDSA_SIG_get0(const ECDSA_SIG *sig, const BIGNUM **pr, const BIGNUM **ps) {
+diff --git a/lib/dns/opensslrsa_link.c b/lib/dns/opensslrsa_link.c
+index 5dddc2e..74e167b 100644
+--- a/lib/dns/opensslrsa_link.c
++++ b/lib/dns/opensslrsa_link.c
+@@ -121,7 +121,7 @@
+ #endif
+ #define DST_RET(a) {ret = a; goto err;}
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ /* From OpenSSL 1.1.0 */
+ static int
+ RSA_set0_key(RSA *r, BIGNUM *n, BIGNUM *e, BIGNUM *d) {