aboutsummaryrefslogtreecommitdiffstats
path: root/main/bluez
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-03 06:59:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-03 07:55:31 +0000
commit3e1b40179b9fd9e3f4c0746bb2be26500867ffea (patch)
tree39ab687b536748f1d24008abec86be77ce6cb968 /main/bluez
parent32b83bc18acf619bd9f4695370f35b3f6c9af6e3 (diff)
downloadaports-3e1b40179b9fd9e3f4c0746bb2be26500867ffea.tar.bz2
aports-3e1b40179b9fd9e3f4c0746bb2be26500867ffea.tar.xz
main/bluez: build deprecated tools
Diffstat (limited to 'main/bluez')
-rw-r--r--main/bluez/APKBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index d32fffcf28..5075daa16e 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=5.44
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
@@ -12,7 +12,7 @@ makedepends="dbus-dev libusb-compat-dev eudev-dev
libical-dev readline-dev glib-dev linux-headers
autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups
- $pkgname-hid2hci"
+ $pkgname-hid2hci $pkgname-deprecated"
source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
bluetooth.initd
rfcomm.initd
@@ -37,6 +37,7 @@ build() {
--libexecdir=/usr/lib \
--disable-systemd \
--enable-library \
+ --enable-deprecated \
|| return 1
make || return 1
}
@@ -66,6 +67,19 @@ hid2hci() {
mv "$pkgdir"/lib "$subpkgdir"/
}
+deprecated() {
+ pkgdesc="Deprecated bluetooth tools"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/ciptool \
+ "$pkgdir"/usr/bin/hciattach \
+ "$pkgdir"/usr/bin/hciconfig \
+ "$pkgdir"/usr/bin/hcidump \
+ "$pkgdir"/usr/bin/hcitool \
+ "$pkgdir"/usr/bin/rfcomm \
+ "$pkgdir"/usr/bin/sdptool \
+ "$subpkgdir"/usr/bin/
+}
+
sha512sums="4ef568816a38cdc990c22ffcb1c1ce7eb44577eafd0dd31178314f5b5c864c5a43c0b4e34c5f013683518c3f2072f18dff6c78660b45aa9ce8554c4b6d43ecf5 bluez-5.44.tar.xz
0a5c652effebe5f2fd968535b2d99e8b9b6983f847fd162f80e5965ade4b7bd12165d27b348506a08503d1bc8c2cf5c8265758ca1e9670dfb5e765edf121fd96 bluetooth.initd
8d7b7c8938a2316ce0a855e9bdf1ef8fcdf33d23f4011df828270a088b88b140a19c432e83fef15355d0829e3c86be05b63e7718fef88563254ea239b8dc12ac rfcomm.initd