aboutsummaryrefslogtreecommitdiffstats
path: root/main/bluez
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-20 07:37:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-20 07:38:52 +0000
commit67566773d498d1209b1f3c09cd1e268b16753712 (patch)
tree17d8b265d2f30ac6a7580ba1f748aef21f8d4e52 /main/bluez
parentbc3c848c80beb38eaa51728896d237a94c2c7f0e (diff)
downloadaports-67566773d498d1209b1f3c09cd1e268b16753712.tar.bz2
aports-67566773d498d1209b1f3c09cd1e268b16753712.tar.xz
main/bluez: split bccmd btmon meshctl and obexd to subpackages
This reduces the size of main bluez package from 3MB to 1.6MB and we avoid the libical and json-c runtime dependencies from main package.
Diffstat (limited to 'main/bluez')
-rw-r--r--main/bluez/APKBUILD30
1 files changed, 27 insertions, 3 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index d6c5a75d5f..15237ba86f 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=5.47
-pkgrel=1
+pkgrel=2
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
@@ -11,8 +11,8 @@ replaces="udev"
makedepends="dbus-dev libusb-compat-dev eudev-dev json-c-dev
libical-dev readline-dev glib-dev linux-headers
autoconf automake libtool"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups
- $pkgname-hid2hci $pkgname-deprecated"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bccmd $pkgname-btmon $pkgname-cups
+ $pkgname-deprecated $pkgname-hid2hci $pkgname-meshctl $pkgname-obexd"
source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
bluetooth.initd
rfcomm.initd
@@ -55,6 +55,18 @@ package() {
install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
}
+bccmd() {
+ pkgdesc="Bluez utility for the CSR BCCMD interface"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/bccmd "$subpkgdir"/usr/bin/
+}
+
+btmon() {
+ pkgdesc="Bluez bluetooth monitor"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/btmon "$subpkgdir"/usr/bin/
+}
+
cups() {
pkgdesc="Bluez backend for CUPS"
mkdir -p "$subpkgdir"/usr/lib/
@@ -81,6 +93,18 @@ deprecated() {
"$subpkgdir"/usr/bin/
}
+meshctl() {
+ pkgdesc="Bluez tool for interacting with bluetooth mesh networks"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/meshctl "$subpkgdir"/usr/bin/
+}
+
+obexd() {
+ pkgdesc="Bluez OBEX daemon"
+ mkdir -p "$subpkgdir"/usr/lib/bluetooth
+ mv "$pkgdir"/usr/lib/bluetooth/obexd "$subpkgdir"/usr/lib/bluetooth
+}
+
sha512sums="86fa1baae1593d4824038db8418358b0be624c81fc23ee8f96ec08979d309a2377be3924ab53cc0fcb712aec8e696360e9a9f4de4c12cc31b14de5cf495a11a6 bluez-5.47.tar.xz
fc43c78ed248ea412529eed5ae8bb47bacca9bf5b3b10de121ddd4e792c85893561a88be4aa2c6318106e5d2146a721445152d44fa60ca257ca0b4eb87318c1e bluetooth.initd
8d7b7c8938a2316ce0a855e9bdf1ef8fcdf33d23f4011df828270a088b88b140a19c432e83fef15355d0829e3c86be05b63e7718fef88563254ea239b8dc12ac rfcomm.initd