aboutsummaryrefslogtreecommitdiffstats
path: root/main/bluez
diff options
context:
space:
mode:
authorRicardo Salveti <rsalveti@rsalveti.net>2017-09-20 01:02:15 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-20 07:13:28 +0000
commitbc3c848c80beb38eaa51728896d237a94c2c7f0e (patch)
tree0f45462f3ba850a7944dabe48e8a5c9202b34080 /main/bluez
parent22327cfeb1e0697ec15a78e146f1cfe1bb4e6519 (diff)
downloadaports-bc3c848c80beb38eaa51728896d237a94c2c7f0e.tar.bz2
aports-bc3c848c80beb38eaa51728896d237a94c2c7f0e.tar.xz
main/bluez: enable bluetooth mesh support
Build and install 'meshctl', which can be used to provision and interact with Bluetooth Mesh networks. json-c-dev was added to makedepends, as it is required by meshctl. Signed-off-by: Ricardo Salveti <rsalveti@rsalveti.net>
Diffstat (limited to 'main/bluez')
-rw-r--r--main/bluez/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index dc4fd98036..d6c5a75d5f 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,14 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=5.47
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
license="GPL2+"
depends="consolekit2 dbus"
replaces="udev"
-makedepends="dbus-dev libusb-compat-dev eudev-dev
+makedepends="dbus-dev libusb-compat-dev eudev-dev json-c-dev
libical-dev readline-dev glib-dev linux-headers
autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups
@@ -38,6 +38,7 @@ build() {
--disable-systemd \
--enable-library \
--enable-deprecated \
+ --enable-mesh \
|| return 1
make || return 1
}