aboutsummaryrefslogtreecommitdiffstats
path: root/main/boost
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-08-14 20:43:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-16 10:08:37 +0000
commit9414a67dfd997ff1e188f0b74c3a9915c6fb80e0 (patch)
treedce2443ddadf403f6b84e2ec1a9cb321b2375099 /main/boost
parent5034463a7f8dceb675256dd68d8740f7a3f4ba74 (diff)
downloadaports-9414a67dfd997ff1e188f0b74c3a9915c6fb80e0.tar.bz2
aports-9414a67dfd997ff1e188f0b74c3a9915c6fb80e0.tar.xz
main/boost: fix and reenable failing debugger tests In debugger::debug_parent_wait() the variable ch was mistakenly defined to be a char and used to obtain a value from ch = fgetc( command_child );
Later in the code a compare of the truncated ch (0xff) to the constant EOF (0xffffffff) would fail resulting in errors between the expected and actual values returned in the debugger.py and debugger-mi.py tests. Since fgetc is defined to return an int the declaration of ch was modified and the truncation eliminated. I will post the patch to the boost/build community as well.
Diffstat (limited to 'main/boost')
-rw-r--r--main/boost/APKBUILD6
-rw-r--r--main/boost/disable-debugger-test.patch15
-rw-r--r--main/boost/fix-fgetc-define.patch11
3 files changed, 14 insertions, 18 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index d2ad0dd246..c2ad659bec 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -2,7 +2,7 @@
pkgname=boost
pkgver=1.67.0
_pkgver="${pkgver//./_}"
-pkgrel=1
+pkgrel=2
pkgdesc="Free peer-reviewed portable C++ source libraries"
url="http://www.boost.org/"
arch="all"
@@ -15,7 +15,7 @@ source="https://dl.bintray.com/boostorg/release/$pkgver/source/${pkgname}_$_pkgv
boost-1.57.0-python-abi_letters.patch
boost-1.57.0-python-libpython_dep.patch
revert-wifsignaled-static-assert.patch
- disable-debugger-test.patch
+ fix-fgetc-define.patch
"
options="!checkroot"
builddir="$srcdir/${pkgname}_${_pkgver}"
@@ -178,4 +178,4 @@ sha512sums="82bf33d7d2c3db109c9d1f12d40bc2d364c8c95262386f906ccd1a71cd71433bcc01
d96d4d37394a31764ed817d0bc4a99cffa68a75ff1ecfd4417b9e1e5ae2c31a96ed24f948c6f2758ffdac01328d2402c4cf0d33a37107e4f5f721e636daebd66 boost-1.57.0-python-abi_letters.patch
132c4b62815d605c2d3c9038427fa4f422612a33711d47b2862f2311516af8a371d6b75bf078a7bffe20be863f8d21fb9fe74dc1a1bac3a10d061e9768ec3e02 boost-1.57.0-python-libpython_dep.patch
1cae6ab9b3b97e0328aa5b85ee2220bb1e88b99256b31bc4a2d06275cf70704c8f4f1bd6abd77386d0490bb14a0393ae981be8e95f2cc054a1dc07de8847e8d5 revert-wifsignaled-static-assert.patch
-20d258303fd4e0644adc0e556b785a6f4e981a116595eb1a104c13b10e00802a7ff4fd086e696e38a311d1ddd400c48eced700234c634c0385fd09bf6f1327be disable-debugger-test.patch"
+ef4eb728daa69b3bb23d53d2554be4dfe35297a21c4966ebf9a4bba19325f4fb251d1de7f9487dcab4632be60b5baf9e53abbd014942a689ba7232d582db1168 fix-fgetc-define.patch"
diff --git a/main/boost/disable-debugger-test.patch b/main/boost/disable-debugger-test.patch
deleted file mode 100644
index c315ef56a2..0000000000
--- a/main/boost/disable-debugger-test.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/tools/build/test/test_all.py b/tools/build/test/test_all.py
-index 9efddc8..abf3dc5 100644
---- a/tools/build/test/test_all.py
-+++ b/tools/build/test/test_all.py
-@@ -206,8 +206,8 @@ tests = ["absolute_sources",
- "core_update_now",
- "core_variables_in_actions",
- "custom_generator",
-- "debugger",
-- "debugger-mi",
-+# "debugger",
-+# "debugger-mi",
- "default_build",
- "default_features",
- # This test is known to be broken itself.
diff --git a/main/boost/fix-fgetc-define.patch b/main/boost/fix-fgetc-define.patch
new file mode 100644
index 0000000000..5922da1204
--- /dev/null
+++ b/main/boost/fix-fgetc-define.patch
@@ -0,0 +1,11 @@
+--- a/tools/build/src/engine/debugger.c
++++ b/tools/build/src/engine/debugger.c
+@@ -978,7 +983,7 @@
+ /* Waits for events from the child. */
+ static void debug_parent_wait( int print_message )
+ {
+- char ch = fgetc( command_child );
++ int ch = fgetc( command_child );
+ if ( ch == DEBUG_MSG_BREAKPOINT )
+ {
+ debug_parent_on_breakpoint();