aboutsummaryrefslogtreecommitdiffstats
path: root/main/boost
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-18 18:21:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-18 18:21:52 +0000
commit9d253b79f3572cb0b901c38b6191f4a5ab45c0b9 (patch)
tree703b55be81f3705a646fd728b8f900548b9aa174 /main/boost
parent4c7193a6a69daef15f804c1884f1b8d4b5a741ac (diff)
downloadaports-9d253b79f3572cb0b901c38b6191f4a5ab45c0b9.tar.bz2
aports-9d253b79f3572cb0b901c38b6191f4a5ab45c0b9.tar.xz
main/boost: upgrade to 1.47.0
Diffstat (limited to 'main/boost')
-rw-r--r--main/boost/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index 3fbec4ac2b..3560977b83 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=boost
-pkgver=1.46.1
+pkgver=1.47.0
_x=${pkgver%%.*} # strip .y.z
_y=${pkgver%.*} # strip .z
@@ -8,7 +8,7 @@ _y=${_y#*.} # strip x.
_z=${pkgver##*.} # strip x.y.
_ver=${_x}_${_y}_${_z}
-pkgrel=1
+pkgrel=0
pkgdesc="Free peer-reviewed portable C++ source libraries"
url="http://www.boost.org/"
arch="all"
@@ -73,7 +73,7 @@ _options="--user-config=\"$_builddir/user-config.jam\"
build() {
msg "Building bjam"
export BOOST_ROOT="$_builddir"
- cd "$_builddir"/tools/build/v2/engine/src
+ cd "$_builddir"/tools/build/v2/engine
CC= ./build.sh cc || return 1
_bindir="bin.linuxx86"
[ "${CARCH}" = "x86_64" ] && _bindir="bin.linuxx86_64"
@@ -133,4 +133,4 @@ wave() { _mvlib wave; }
wserialization() { _mvlib wserialization; }
-md5sums="341e5d993b19d099bf1a548495ea91ec boost_1_46_1.tar.gz"
+md5sums="ff180a5276bec773a7625cac7e2288e8 boost_1_47_0.tar.gz"