aboutsummaryrefslogtreecommitdiffstats
path: root/main/boost
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-04-23 11:50:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-04-23 11:50:24 +0000
commitafd8b94a400d52f3df122711c097119b2de92d1e (patch)
tree6b23224835cc41a6b414aa82231861c6ba8fd415 /main/boost
parentf116ec22f9bc36412d202acd3d1419db97f8f7bc (diff)
downloadaports-afd8b94a400d52f3df122711c097119b2de92d1e.tar.bz2
aports-afd8b94a400d52f3df122711c097119b2de92d1e.tar.xz
main/boost: upgrade to 1.53.0
Diffstat (limited to 'main/boost')
-rw-r--r--main/boost/APKBUILD12
-rw-r--r--main/boost/stdint.patch13
-rw-r--r--main/boost/uclibc-stdint.patch13
3 files changed, 21 insertions, 17 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index 3f75c4bcf7..34338ad92a 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=boost
-pkgver=1.52.0
+pkgver=1.53.0
_x=${pkgver%%.*} # strip .y.z
_y=${pkgver%.*} # strip .z
@@ -35,7 +35,7 @@ $pkgname-wave
$pkgname-wserialization
"
source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$_ver.tar.gz
- uclibc-stdint.patch
+ stdint.patch
"
_builddir="$srcdir"/${pkgname}_${_ver}
@@ -134,5 +134,9 @@ wave() { _mvlib wave; }
wserialization() { _mvlib wserialization; }
-md5sums="f62451fa646ca392b0fbc08beb23ad12 boost_1_52_0.tar.gz
-56e28d906362cf7fa83de8f72b3bc880 uclibc-stdint.patch"
+md5sums="57a9e2047c0f511c4dfcf00eb5eb2fbb boost_1_53_0.tar.gz
+44d1879459159367448967a2c43c36d1 stdint.patch"
+sha256sums="7c4d1515e0310e7f810cbbc19adb9b2d425f443cc7a00b4599742ee1bdfd4c39 boost_1_53_0.tar.gz
+b48f6ba5ffbc04c88dedb6b6639d2870a8f0901693d762f5c8d2e912d8ab47a6 stdint.patch"
+sha512sums="1787ba1b156d5a40f027b401815e7bc5137f3aa52c8d457115154455b976f8abbb88dbb89d5876b23ddbf5761ad0d69f6b3d8267e7e885e6a73db69e15c3a75e boost_1_53_0.tar.gz
+b964488c9c74d89a55480b3a0078d4e7a19df91c9a7ba9ea2695142b54335191a3c0fbb004893c03b498bc270680403e1ba3681eb94ef4407a70f0727aa66c0a stdint.patch"
diff --git a/main/boost/stdint.patch b/main/boost/stdint.patch
new file mode 100644
index 0000000000..65e838d3ad
--- /dev/null
+++ b/main/boost/stdint.patch
@@ -0,0 +1,13 @@
+--- ./boost/atomic/atomic.hpp.orig 2013-04-23 11:44:45.556751918 +0000
++++ ./boost/atomic/atomic.hpp 2013-04-23 11:45:44.944031100 +0000
+@@ -8,6 +8,10 @@
+ // http://www.boost.org/LICENSE_1_0.txt)
+
+ #include <cstddef>
++extern "C" {
++#include <stdint.h>
++}
++
+ #include <boost/cstdint.hpp>
+
+ #include <boost/memory_order.hpp>
diff --git a/main/boost/uclibc-stdint.patch b/main/boost/uclibc-stdint.patch
deleted file mode 100644
index 3aed6333d6..0000000000
--- a/main/boost/uclibc-stdint.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/libs/context/src/fcontext.cpp.new 2012-12-11 17:59:59.349131458 +0100
-+++ b/libs/context/src/fcontext.cpp 2012-12-11 18:00:06.925131652 +0100
-@@ -9,6 +9,9 @@
- #include <boost/context/fcontext.hpp>
-
- #include <cstddef>
-+extern "C" {
-+#include <stdint.h>
-+}
-
- #ifdef BOOST_HAS_ABI_HEADERS
- # include BOOST_ABI_PREFIX
-