aboutsummaryrefslogtreecommitdiffstats
path: root/main/boost
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-13 18:31:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-13 18:32:23 +0000
commitc142bf9d2829c372c592e015a1132bf066716c7f (patch)
tree2b9cfd921c05717337364e057bc664edb5431c07 /main/boost
parent6f045014a5e150acf84e794a924a8c92a39c0370 (diff)
downloadaports-c142bf9d2829c372c592e015a1132bf066716c7f.tar.bz2
aports-c142bf9d2829c372c592e015a1132bf066716c7f.tar.xz
main/boost: disable debugger tests
those fail on aarch64, armhf, ppc64le ans s390x
Diffstat (limited to 'main/boost')
-rw-r--r--main/boost/APKBUILD4
-rw-r--r--main/boost/disab0
-rw-r--r--main/boost/disable-debugger-test.patch15
3 files changed, 18 insertions, 1 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index 7a15c23d99..d2ad0dd246 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -15,6 +15,7 @@ source="https://dl.bintray.com/boostorg/release/$pkgver/source/${pkgname}_$_pkgv
boost-1.57.0-python-abi_letters.patch
boost-1.57.0-python-libpython_dep.patch
revert-wifsignaled-static-assert.patch
+ disable-debugger-test.patch
"
options="!checkroot"
builddir="$srcdir/${pkgname}_${_pkgver}"
@@ -176,4 +177,5 @@ _pyversion() {
sha512sums="82bf33d7d2c3db109c9d1f12d40bc2d364c8c95262386f906ccd1a71cd71433bcc01829e968b4a13a5003cf0b50cbdf0b435a1d76530cea7bb05725c327411e8 boost_1_67_0.tar.bz2
d96d4d37394a31764ed817d0bc4a99cffa68a75ff1ecfd4417b9e1e5ae2c31a96ed24f948c6f2758ffdac01328d2402c4cf0d33a37107e4f5f721e636daebd66 boost-1.57.0-python-abi_letters.patch
132c4b62815d605c2d3c9038427fa4f422612a33711d47b2862f2311516af8a371d6b75bf078a7bffe20be863f8d21fb9fe74dc1a1bac3a10d061e9768ec3e02 boost-1.57.0-python-libpython_dep.patch
-1cae6ab9b3b97e0328aa5b85ee2220bb1e88b99256b31bc4a2d06275cf70704c8f4f1bd6abd77386d0490bb14a0393ae981be8e95f2cc054a1dc07de8847e8d5 revert-wifsignaled-static-assert.patch"
+1cae6ab9b3b97e0328aa5b85ee2220bb1e88b99256b31bc4a2d06275cf70704c8f4f1bd6abd77386d0490bb14a0393ae981be8e95f2cc054a1dc07de8847e8d5 revert-wifsignaled-static-assert.patch
+20d258303fd4e0644adc0e556b785a6f4e981a116595eb1a104c13b10e00802a7ff4fd086e696e38a311d1ddd400c48eced700234c634c0385fd09bf6f1327be disable-debugger-test.patch"
diff --git a/main/boost/disab b/main/boost/disab
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/main/boost/disab
diff --git a/main/boost/disable-debugger-test.patch b/main/boost/disable-debugger-test.patch
new file mode 100644
index 0000000000..c315ef56a2
--- /dev/null
+++ b/main/boost/disable-debugger-test.patch
@@ -0,0 +1,15 @@
+diff --git a/tools/build/test/test_all.py b/tools/build/test/test_all.py
+index 9efddc8..abf3dc5 100644
+--- a/tools/build/test/test_all.py
++++ b/tools/build/test/test_all.py
+@@ -206,8 +206,8 @@ tests = ["absolute_sources",
+ "core_update_now",
+ "core_variables_in_actions",
+ "custom_generator",
+- "debugger",
+- "debugger-mi",
++# "debugger",
++# "debugger-mi",
+ "default_build",
+ "default_features",
+ # This test is known to be broken itself.