aboutsummaryrefslogtreecommitdiffstats
path: root/main/boost
diff options
context:
space:
mode:
authorAmatCoder <AmatCoder@users.noreply.github.com>2016-05-20 12:33:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-20 13:26:11 +0000
commitd2e31d2e977024525f5164c57e6a7527ac217e25 (patch)
tree379d22b2a18cf1b5bde935c1a98e0def2cdc3188 /main/boost
parent82cb12b466cc79ae9d32bc3703ae60126a7bea0a (diff)
downloadaports-d2e31d2e977024525f5164c57e6a7527ac217e25.tar.bz2
aports-d2e31d2e977024525f5164c57e6a7527ac217e25.tar.xz
main/boost: Fix unresolved references from boost_python
Diffstat (limited to 'main/boost')
-rw-r--r--main/boost/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index bb08bcd9fa..343a9d8035 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -8,7 +8,7 @@ _y=${_y#*.} # strip x.
_z=${pkgver##*.} # strip x.y.
_ver=${_x}_${_y}_${_z}
-pkgrel=1
+pkgrel=2
pkgdesc="Free peer-reviewed portable C++ source libraries"
url="http://www.boost.org/"
arch="all"
@@ -56,6 +56,7 @@ prepare() {
cat > user-config.jam <<__EOF__
using gcc : : $CC : <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
+using python : ${PY2_VERSION} : /usr/bin/python : /usr/include/python${PY2_VERSION} : /usr/lib ;
using python : ${PY3_VERSION} : /usr/bin/python3 : /usr/include/python${PY3_VERSION}m : /usr/lib ;
__EOF__