aboutsummaryrefslogtreecommitdiffstats
path: root/main/flex
diff options
context:
space:
mode:
authorArch3y <arch3y@arch3y.com>2017-05-08 20:46:20 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-10 20:15:54 +0000
commitfcb859f95a434a01352bb86e4233ef0b3c3e50e5 (patch)
tree55e9aa455afe8b7695fb0dc28f6f8ba4570770f9 /main/flex
parentc6f31c458a213bf82cf3c28bfa78b850dace3922 (diff)
downloadaports-fcb859f95a434a01352bb86e4233ef0b3c3e50e5.tar.bz2
aports-fcb859f95a434a01352bb86e4233ef0b3c3e50e5.tar.xz
main/flex - updated flex to 2.6.4
Added check function and updated to 2.6.4 This will fix build issues with unbound
Diffstat (limited to 'main/flex')
-rw-r--r--main/flex/APKBUILD24
-rw-r--r--main/flex/fix-yywrap.patch27
2 files changed, 14 insertions, 37 deletions
diff --git a/main/flex/APKBUILD b/main/flex/APKBUILD
index 543b524b9c..4983841a7e 100644
--- a/main/flex/APKBUILD
+++ b/main/flex/APKBUILD
@@ -1,6 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Arch3y <arch3y@riseup.net>
pkgname=flex
-pkgver=2.6.3
+pkgver=2.6.4
pkgrel=1
pkgdesc="A tool for generating text-scanning programs"
url="https://github.com/westes/flex"
@@ -10,10 +11,10 @@ depends="m4"
depends_dev="flex"
makedepends="$depends_dev m4 bison help2man"
subpackages="$pkgname-doc $pkgname-libs $pkgname-dev"
-source="https://github.com/westes/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
- fix-yywrap.patch"
+source="https://github.com/westes/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
+
build() {
cd "$builddir"
./configure \
@@ -23,16 +24,19 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--disable-static \
- --enable-shared \
- || return 1
- make || return 1
+ --enable-shared
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
cd "$builddir"
- make install DESTDIR="$pkgdir" || return 1
- ln -s flex "$pkgdir"/usr/bin/lex || return 1
+ make install DESTDIR="$pkgdir"
+ ln -s flex "$pkgdir"/usr/bin/lex
}
-sha512sums="f14b1af7ddd148660737991787fcf13d86cc0bef3859ed6c2135963373e76524d70382795c845cb6491b0435f8c40ba81e17f15267592b8d1656cfd4c3430b00 flex-2.6.3.tar.gz
-c1f50405102b6e74d3c21206aab4419a42d12931454d858e8cb7b617773338ea3ff34e4ed8813998709f515da42e98bca0123607bcf77fb74e61acb0cf30a2f9 fix-yywrap.patch"
+sha512sums="e9785f3d620a204b7d20222888917dc065c2036cae28667065bf7862dfa1b25235095a12fd04efdbd09bfd17d3452e6b9ef953a8c1137862ff671c97132a082e flex-2.6.4.tar.gz"
diff --git a/main/flex/fix-yywrap.patch b/main/flex/fix-yywrap.patch
deleted file mode 100644
index 39dd8852ad..0000000000
--- a/main/flex/fix-yywrap.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From f5d87f1a26f4a5c3402497008ae10e9a1345d327 Mon Sep 17 00:00:00 2001
-From: Christos Zoulas <christos@zoulas.com>
-Date: Sun, 22 Jan 2017 18:20:44 +0100
-Subject: [PATCH] scanner: Use prefix when defining yywrap to avoid
- redefinition.
-
-Fixes regression introduced in v2.6.3.
----
- src/main.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/main.c b/src/main.c
-index f70b1aa..83f66b0 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -1586,9 +1586,9 @@ void readin (void)
- if (!do_yywrap) {
- if (!C_plus_plus) {
- if (reentrant)
-- outn ("\n#define yywrap(yyscanner) (/*CONSTCOND*/1)");
-+ out_str ("\n#define %swrap(yyscanner) (/*CONSTCOND*/1)\n", prefix);
- else
-- outn ("\n#define yywrap() (/*CONSTCOND*/1)");
-+ out_str ("\n#define %swrap() (/*CONSTCOND*/1)\n", prefix);
- }
- outn ("#define YY_SKIP_YYWRAP");
- }