aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-07 19:30:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-09 19:58:32 +0000
commitc79dfa20652a27ae3564db7d61fc8f483f3af685 (patch)
treed539ebf5207dc31fac24b2040c14aa7ec452c5b7 /main/freeswitch
parentaf1406a0528ed4445ad42aa3d339092e4abbe291 (diff)
downloadaports-c79dfa20652a27ae3564db7d61fc8f483f3af685.tar.bz2
aports-c79dfa20652a27ae3564db7d61fc8f483f3af685.tar.xz
main/freeswitch: upgrade to 1.6.19
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch34
-rw-r--r--main/freeswitch/APKBUILD32
2 files changed, 51 insertions, 15 deletions
diff --git a/main/freeswitch/0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch b/main/freeswitch/0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch
new file mode 100644
index 0000000000..3de8c54572
--- /dev/null
+++ b/main/freeswitch/0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch
@@ -0,0 +1,34 @@
+From 9d96741f56b7f663fd1b0ad625b4b7042832ebca Mon Sep 17 00:00:00 2001
+From: Italo Rossi <italorossib@gmail.com>
+Date: Mon, 6 Nov 2017 10:35:36 -0300
+Subject: [PATCH] FS-10774 - [switch_pgsql] Fix build for PostgreSQL/libpq 10
+
+---
+ src/switch_pgsql.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/switch_pgsql.c b/src/switch_pgsql.c
+index 7928624270..f3411361fd 100644
+--- a/src/switch_pgsql.c
++++ b/src/switch_pgsql.c
+@@ -386,7 +386,7 @@ SWITCH_DECLARE(switch_pgsql_status_t) switch_pgsql_next_result_timed(switch_pgsq
+ *result_out = res;
+ res->status = PQresultStatus(res->result);
+ switch(res->status) {
+-#if POSTGRESQL_MAJOR_VERSION >= 9 && POSTGRESQL_MINOR_VERSION >= 2
++#if (POSTGRESQL_MAJOR_VERSION == 9 && POSTGRESQL_MINOR_VERSION >= 2) || POSTGRESQL_MAJOR_VERSION > 9
+ case PGRES_SINGLE_TUPLE:
+ /* Added in PostgreSQL 9.2 */
+ #endif
+@@ -397,7 +397,7 @@ SWITCH_DECLARE(switch_pgsql_status_t) switch_pgsql_next_result_timed(switch_pgsq
+ res->cols = PQnfields(res->result);
+ }
+ break;
+-#if POSTGRESQL_MAJOR_VERSION >= 9 && POSTGRESQL_MINOR_VERSION >= 1
++#if (POSTGRESQL_MAJOR_VERSION == 9 && POSTGRESQL_MINOR_VERSION >= 1) || POSTGRESQL_MAJOR_VERSION > 9
+ case PGRES_COPY_BOTH:
+ /* Added in PostgreSQL 9.1 */
+ #endif
+--
+2.15.0
+
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 6345980988..4faaa9c91b 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Contributor: Cameron Banta <cbanta@gmail.com>
pkgname=freeswitch
-pkgver=1.6.17
+pkgver=1.6.19
pkgrel=0
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
@@ -60,6 +60,7 @@ subpackages="$pkgname-dbg $pkgname-dev $pkgname-flite $pkgname-timezones::noarch
$pkgname-snmp $pkgname-pgsql $pkgname-perl $pkgname-perlesl"
source="http://files.freeswitch.org/freeswitch-releases/$pkgname-$pkgver.tar.xz
+ 0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch
0001-mod_avmd-use-posix-isinf.patch
0001-sofia-sip-byte-order.patch
0002-FS-verto-bswap_64.patch
@@ -73,13 +74,13 @@ source="http://files.freeswitch.org/freeswitch-releases/$pkgname-$pkgver.tar.xz
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
update_config_sub
}
build() {
cd "$builddir"
- cp -f "$srcdir/modules.conf" modules.conf || return 1
+ cp -f "$srcdir/modules.conf" modules.conf
CFLAGS="-Wno-unused-but-set-variable" ./configure \
--build=$CBUILD \
@@ -96,29 +97,29 @@ build() {
--disable-debug \
--enable-core-pgsql-support \
--enable-system-lua \
- --enable-system-xmlrpc-c \
- || return 1
+ --enable-system-xmlrpc-c
+ # build freetdm with -lexecinfo
+ make -C libs/freetdm LIBS="-lexecinfo"
# first build libfreeswitch (in parallel)
make src/include/switch_version.h src/include/switch_swigable_cpp.h
- make libfreeswitch.la || return 1
+ make libfreeswitch.la
# finally we build the rest
- make -j1 all || return 1
+ make -j1 all
# build perlesl module
cd "$builddir"/libs/esl
- make -j1 perlmod || return 1
+ make -j1 perlmod
}
package(){
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install samples-conf samples-htdocs \
- || return 1
+ make -j1 DESTDIR="$pkgdir" install samples-conf samples-htdocs
install -m755 -D "$srcdir"/$pkgname.initd \
- "$pkgdir"/etc/init.d/$pkgname || return 1
+ "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd \
- "$pkgdir"/etc/conf.d/$pkgname || return 1
+ "$pkgdir"/etc/conf.d/$pkgname
chown -R $FREESWITCH_USER:$FREESWITCH_GROUP "$pkgdir"/var/*/freeswitch
# install perlesl module
@@ -131,7 +132,7 @@ _mv_mod() {
local moddir=usr/lib/freeswitch/mod i=
mkdir -p "$subpkgdir"/$moddir
for i in $@; do
- mv "$pkgdir"/$moddir/$i.so "$subpkgdir"/$moddir/ || return 1
+ mv "$pkgdir"/$moddir/$i.so "$subpkgdir"/$moddir/
done
}
@@ -205,12 +206,13 @@ conf() {
# move all configs except freeswitch.xml
for i in "$pkgdir"/etc/freeswitch/*; do
[ "$i" = "$pkgdir"/etc/freeswitch/freeswitch.xml ] && continue
- mv "$i" "$subpkgdir"/etc/freeswitch/ || return 1
+ mv "$i" "$subpkgdir"/etc/freeswitch/
done
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-sha512sums="09859c16fee07d6b7f8a54f7149bc56b49ef82d4fdf6df97df2611d117f3a6256f68bfaf19e4a307c9da0b7c80b942f02e5be4a85df3cc3f0f0a5f75ad731fa8 freeswitch-1.6.17.tar.xz
+sha512sums="2cf678b7035e17d05f3745921dccafd2fb874cf927fdde5bd274cc07a42e372e941bedaa9569c59d09882eed02de9e874661a64a165e3de860fa6be7adc365ae freeswitch-1.6.19.tar.xz
+db61d9a253105f7a1ef5f5c218b367a833f62a2e85e364e3971acc79f68037b0270c5b2f3e0909643278b6b93104ac8e59b323470aeef5f519c33b0289c0fcf3 0001-FS-10774-switch_pgsql-Fix-build-for-PostgreSQL-libpq.patch
482f9804b1c6e4120b4085885650c1b15006de629e475ca16d03feb314ce8816523b349217d10e80ba5a1aeead1090d8398bb05102bd9f2ebe673869286815ad 0001-mod_avmd-use-posix-isinf.patch
8a7ca31cc80524b02edc83af891a32af64dd7834ac14b1389112f2ce7fe06fe602d24509a299898f25e807dd0b88544aecb990bf4bd37ee1c7023ae58dacd28a 0001-sofia-sip-byte-order.patch
5f93150e1acd632df98bc3bed5613fb1e45180ae4096dcfee5c060da213c8355339260eaf5758cd77c785f6d84cf0661650a872ec574b586ab19803d4f6955f8 0002-FS-verto-bswap_64.patch