aboutsummaryrefslogtreecommitdiffstats
path: root/main/gdk-pixbuf
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-05 15:24:12 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-05 15:29:20 +0200
commit4ebee3534791a84ec23422f110dc7d1334273f70 (patch)
treeb4ac645336eb0bb5fe152145530b31a1c609e4d7 /main/gdk-pixbuf
parent410bd401e8f86cf2062bb7b61ffdc5238d69dc00 (diff)
downloadaports-4ebee3534791a84ec23422f110dc7d1334273f70.tar.bz2
aports-4ebee3534791a84ec23422f110dc7d1334273f70.tar.xz
main/gdk-pixbuf: security upgrade to 2.32.1
ref #4733 fixes #4734
Diffstat (limited to 'main/gdk-pixbuf')
-rw-r--r--main/gdk-pixbuf/APKBUILD15
-rw-r--r--main/gdk-pixbuf/glibc-malloc.patch28
2 files changed, 38 insertions, 5 deletions
diff --git a/main/gdk-pixbuf/APKBUILD b/main/gdk-pixbuf/APKBUILD
index 41d6f08d5a..547c227777 100644
--- a/main/gdk-pixbuf/APKBUILD
+++ b/main/gdk-pixbuf/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdk-pixbuf
-pkgver=2.31.5
+pkgver=2.32.1
pkgrel=0
pkgdesc="GDK Pixbuf library"
url="http://www.gtk.org/"
@@ -12,7 +12,9 @@ makedepends="$depends_dev tiff-dev libjpeg-turbo-dev gobject-introspection-dev"
install="$pkgname.pre-deinstall"
triggers="$pkgname.trigger=/usr/lib/gdk-pixbuf-2.0/*/loaders"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://ftp.gnome.org/pub/gnome/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz"
+source="http://ftp.gnome.org/pub/gnome/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz
+ glibc-malloc.patch
+ "
replaces="gtk+"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -55,6 +57,9 @@ dev() {
default_dev
}
-md5sums="09bbce27f9a1ab5024ece39ceca219c9 gdk-pixbuf-2.31.5.tar.xz"
-sha256sums="0a76e70497cd25ef2ac0da63a489c158ea3926724eb83d5254f9a0bc985ff7a6 gdk-pixbuf-2.31.5.tar.xz"
-sha512sums="9488d235c5588821613276e9ea67e5ec4910060adc9f10c84fbd2fec58bc504b3d926cf14facfede43baccc8a9ef4fd677c62d4ee9533a7dc9870a7bf2a3d04a gdk-pixbuf-2.31.5.tar.xz"
+md5sums="b1590189a2e89fab9f871959c168508c gdk-pixbuf-2.32.1.tar.xz
+c65938b5827467f1a0743c8ba96aa27d glibc-malloc.patch"
+sha256sums="4432b74f25538c7d6bcb3ca51adabdd666168955f25812a2568dc9637697f3bc gdk-pixbuf-2.32.1.tar.xz
+60fe43700c5a380d4b9e14669b54c99eba755d7fa5d780aabea6ef13bdc59387 glibc-malloc.patch"
+sha512sums="4c744f166e86c17cafebe0db9434794666b64850a60597e34675cf9b902e48e89c3ff45032a10899944ae59b6c0db63c1ff33c4d2c50846393e77bad3a3adec2 gdk-pixbuf-2.32.1.tar.xz
+5bdcc5e3fad53e9faf7c86fe3310e4a111dbce5c979f93d3b9e816af0f368f40782fa2195a1e5097838b17ca7f6195c2546a6055c7323025bdcd4323fdf5f5e0 glibc-malloc.patch"
diff --git a/main/gdk-pixbuf/glibc-malloc.patch b/main/gdk-pixbuf/glibc-malloc.patch
new file mode 100644
index 0000000000..6986d17464
--- /dev/null
+++ b/main/gdk-pixbuf/glibc-malloc.patch
@@ -0,0 +1,28 @@
+Work around for a test that should not build on non-glibc systems.
+
+Problem and proper fix is reported to:
+https://bugzilla.gnome.org/show_bug.cgi?id=756078
+
+diff --git a/tests/pixbuf-lowmem.c b/tests/pixbuf-lowmem.c
+index ae71788..9e9571f 100644
+--- a/tests/pixbuf-lowmem.c
++++ b/tests/pixbuf-lowmem.c
+@@ -24,6 +24,7 @@
+ #include <time.h>
+ #include <string.h>
+
++#ifdef __GLIBC__
+ #define PRETEND_MEM_SIZE (16 * 1024 * 1024)
+ #define REMAINING_MEM_SIZE 100000
+
+@@ -225,3 +226,10 @@ main (int argc, char **argv)
+
+ return 0;
+ }
++#else
++int
++main (int argc, char **argv)
++{
++ return 0;
++}
++#endif