aboutsummaryrefslogtreecommitdiffstats
path: root/main/gdk-pixbuf
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-05 18:37:37 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-07 07:49:58 +0000
commitc4aadba45e0bd8682e966861f1057acdbbd2ecc7 (patch)
treed67d907f084df1573f5f49e88751585ecf61aed5 /main/gdk-pixbuf
parent40bc696c61e47dc558de3caf24758b3fa6a501ee (diff)
downloadaports-c4aadba45e0bd8682e966861f1057acdbbd2ecc7.tar.bz2
aports-c4aadba45e0bd8682e966861f1057acdbbd2ecc7.tar.xz
main/gdk-pixbuf: modernise, fix metadata, add check
- License is LGPL-2.0+ - Explicitly pass options to configure to ensure the desired options are enabled - More accurately describe the package in pkgdesc
Diffstat (limited to 'main/gdk-pixbuf')
-rw-r--r--main/gdk-pixbuf/APKBUILD34
1 files changed, 15 insertions, 19 deletions
diff --git a/main/gdk-pixbuf/APKBUILD b/main/gdk-pixbuf/APKBUILD
index 7fe9cdbba5..89a160d9a0 100644
--- a/main/gdk-pixbuf/APKBUILD
+++ b/main/gdk-pixbuf/APKBUILD
@@ -1,15 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdk-pixbuf
pkgver=2.36.11
-pkgrel=0
-pkgdesc="GDK Pixbuf library"
+pkgrel=1
+pkgdesc="GTK+ image loading library"
url="https://www.gtk.org/"
arch="all"
-license="LGPL"
+license="LGPL-2.0+"
depends="shared-mime-info"
depends_dev=""
makedepends="$depends_dev tiff-dev libjpeg-turbo-dev gobject-introspection-dev
-libpng-dev glib-dev"
+ libpng-dev glib-dev"
install="$pkgname.pre-deinstall"
triggers="$pkgname.trigger=/usr/lib/gdk-pixbuf-2.0/*/loaders"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
@@ -19,25 +19,14 @@ source="https://download.gnome.org/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$p
"
replaces="gtk+"
-_builddir="$srcdir"/$pkgname-$pkgver
-
# secfixes:
# 2.36.6-r1:
# - CVE-2017-6311
# - CVE-2017-6312
# - CVE-2017-6314
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -46,12 +35,19 @@ build() {
--with-x11 \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- || return 1
- make || return 1
+ --with-libjpeg \
+ --with-libtiff \
+ --enable-introspection
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}