aboutsummaryrefslogtreecommitdiffstats
path: root/main/geoip/geoip.cron
diff options
context:
space:
mode:
authorDaniel Isaksen <d@duniel.no>2018-01-28 19:08:40 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-02-12 09:58:37 +0000
commit46026ea826f5d0507f85a9800b220e47da7b1206 (patch)
tree5d494f847a8cc5d38a95bb673b0a7a4ba55533e4 /main/geoip/geoip.cron
parent686332495415a6dd39768ab832e74d04f968b58c (diff)
downloadaports-46026ea826f5d0507f85a9800b220e47da7b1206.tar.bz2
aports-46026ea826f5d0507f85a9800b220e47da7b1206.tar.xz
main/geoip: download additional databases from MaxMind
Modernize APKBUILD
Diffstat (limited to 'main/geoip/geoip.cron')
-rwxr-xr-xmain/geoip/geoip.cron5
1 files changed, 5 insertions, 0 deletions
diff --git a/main/geoip/geoip.cron b/main/geoip/geoip.cron
index fc96d08a82..8d74aff5cf 100755
--- a/main/geoip/geoip.cron
+++ b/main/geoip/geoip.cron
@@ -1,2 +1,7 @@
#!/bin/sh
wget -q http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz -O /tmp/GeoIP.dat.gz && gunzip /tmp/GeoIP.dat.gz && mv /tmp/GeoIP.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/GeoIPv6.dat.gz -O /tmp/GeoIPv6.dat.gz && gunzip /tmp/GeoIPv6.dat.gz && mv /tmp/GeoIPv6.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz -O /tmp/GeoLiteCity.dat.gz && gunzip /tmp/GeoLiteCity.dat.gz && mv /tmp/GeoLiteCity.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz -O /tmp/GeoLiteCityv6.dat.gz && gunzip /tmp/GeoLiteCityv6.dat.gz && mv /tmp/GeoLiteCityv6.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz -O /tmp/GeoIPASNum.dat.gz && gunzip /tmp/GeoIPASNum.dat.gz && mv /tmp/GeoIPASNum.dat /usr/share/GeoIP
+wget -q http://geolite.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz -O /tmp/GeoIPASNumv6.dat.gz && gunzip /tmp/GeoIPASNumv6.dat.gz && mv /tmp/GeoIPASNumv6.dat /usr/share/GeoIP