aboutsummaryrefslogtreecommitdiffstats
path: root/main/ghostscript/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-09-28 18:33:51 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-09-28 18:34:09 +0200
commit046890ed1f494f0923823394d16f2df54736037e (patch)
tree9b0ffb86089f36f0b460e797cc4d6faf7b3d27fb /main/ghostscript/APKBUILD
parent53cddefdd460b2af43eeb7e342312c47f450b5ea (diff)
downloadaports-046890ed1f494f0923823394d16f2df54736037e.tar.bz2
aports-046890ed1f494f0923823394d16f2df54736037e.tar.xz
main/ghostscript: upgrade to 9.20
Diffstat (limited to 'main/ghostscript/APKBUILD')
-rw-r--r--main/ghostscript/APKBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/main/ghostscript/APKBUILD b/main/ghostscript/APKBUILD
index 36f68533b0..3b7010ab84 100644
--- a/main/ghostscript/APKBUILD
+++ b/main/ghostscript/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Cameron Banta <cbanta@gmail.com>
# Maintainer: Cameron Banta <cbanta@gmail.com>
pkgname=ghostscript
-pkgver=9.19
-pkgrel=1
+pkgver=9.20
+pkgrel=0
pkgdesc="An interpreter for the PostScript language and for PDF"
url="http://ghostscript.com/"
arch="all"
@@ -15,8 +15,7 @@ source="https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/
ghostscript-system-zlib.patch
fix-sprintf.patch
"
-# ghostscript-system-openjpeg2.patch
-builddir="$srcdir/ghostscript-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$builddir"
@@ -71,19 +70,18 @@ build(){
--with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
--disable-compile-inits \
|| return 1
- make so all
+ make so all || return 1
}
package() {
cd "$builddir"
- make -j1 DESTDIR="${pkgdir}" install soinstall || return 1
+ make -j1 DESTDIR="$pkgdir" install soinstall || return 1
cd "$builddir"/ijs
- make -j1 DESTDIR="${pkgdir}" install || return 1
- cd..
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ cd ..
-
- #create empty dir for future fonts
+ # create empty dir for future fonts
mkdir -p "${pkgdir}"/usr/share/fonts/Type1
# license and copying
@@ -95,8 +93,10 @@ package() {
# make the doc and examples more alpine like
# (the --docdir above doesn't seem to work so good)
mkdir -p "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/share/$pkgname/$pkgver/doc" "$pkgdir/usr/share/doc/$pkgname"
- mv "$pkgdir/usr/share/$pkgname/$pkgver/examples" "$pkgdir/usr/share/doc/$pkgname"
+ mv "$pkgdir/usr/share/$pkgname/$pkgver/doc" \
+ "$pkgdir/usr/share/doc/$pkgname" || return 1
+ mv "$pkgdir/usr/share/$pkgname/$pkgver/examples" \
+ "$pkgdir/usr/share/doc/$pkgname" || return 1
}
gtk() {
@@ -106,12 +106,12 @@ gtk() {
mv "$pkgdir"/usr/bin/gsx "$subpkgdir"/usr/bin/
}
-md5sums="c9682ce6b852f9197c69905a43928907 ghostscript-9.19.tar.gz
+md5sums="93c5987cd3ab341108be1ebbaadc24fe ghostscript-9.20.tar.gz
ae582371ec56fd8f73349773f23dcc94 ghostscript-system-zlib.patch
ee7da55d7a714db1de0fa78253cdacf3 fix-sprintf.patch"
-sha256sums="cf3c0dce67db1557a87366969945f9c5235887989c0b585e037af366dc035989 ghostscript-9.19.tar.gz
+sha256sums="949b64b46ecf8906db54a94ecf83ab97534ebf946f770d3c3f283cb469cb6e14 ghostscript-9.20.tar.gz
56662fae7956e741059ef9c2b5a7e883ab04d78acf5dae4fddf4a661f47f8b67 ghostscript-system-zlib.patch
6e01bd26ade307414f86a5d8f00c97719830d8afd49ffe84224ae47498de7a54 fix-sprintf.patch"
-sha512sums="7575564be7596340af7eb0993d3d8ad5d6ba5fea0c07f470c88b280c0bef1c0dba9875d8ecc84fd87177915fd6166bc7db5929e4f053ba33472eae01b818e0ab ghostscript-9.19.tar.gz
+sha512sums="6c9d4f669a43192119cfe1a3d8070f3024fe08ebbbc1aa906781a71d9c08c87e0b3a215e01cdf33be671bdb7400bb641b5a65d45e1b15f8c5ccaaae202fa774c ghostscript-9.20.tar.gz
70721e3a335afa5e21d4e6cf919119010bd4544a03ab8f53f5325c173902221ad9b88c118b4bfeee80b3e1956bcdbaf4c53f64ae7fb81f5ba57dbc956750c482 ghostscript-system-zlib.patch
beefcf395f7f828e1b81c088022c08a506e218f27535b9de01e0f0edf7979b435316c318fa676771630f6ad16ff1ab059cd68aa128ed97e5a9f2f3fa840200c4 fix-sprintf.patch"