aboutsummaryrefslogtreecommitdiffstats
path: root/main/graphite2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-24 08:03:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-24 08:04:00 +0000
commit141dcb9ec47fa2cc0234c92bd232d908ada71c93 (patch)
tree9b5c7823a90618483ef15ca8dda77bc107e5fb8b /main/graphite2
parentfc93d161b9c7ae99c615779d67571fe85be1392a (diff)
downloadaports-141dcb9ec47fa2cc0234c92bd232d908ada71c93.tar.bz2
aports-141dcb9ec47fa2cc0234c92bd232d908ada71c93.tar.xz
main/graphite2: upgrade to 1.3.12
Diffstat (limited to 'main/graphite2')
-rw-r--r--main/graphite2/APKBUILD10
-rw-r--r--main/graphite2/cmake.patch16
-rw-r--r--main/graphite2/graphite2-1.2.0-cmakepath.patch9
3 files changed, 3 insertions, 32 deletions
diff --git a/main/graphite2/APKBUILD b/main/graphite2/APKBUILD
index cb8c41e763..249096b79c 100644
--- a/main/graphite2/APKBUILD
+++ b/main/graphite2/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=graphite2
_realname=${pkgname/2/}
-pkgver=1.3.11
-pkgrel=1
+pkgver=1.3.12
+pkgrel=0
pkgdesc="reimplementation of the SIL Graphite text processing engine"
url="http://graphite.sil.org/"
arch="all"
@@ -15,8 +15,6 @@ makedepends="$depends_dev cmake"
install=""
subpackages="$pkgname-static $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/silnrsi/$_realname/archive/$pkgver.tar.gz
- graphite2-1.2.0-cmakepath.patch
- cmake.patch
"
builddir="$srcdir"/$_realname-$pkgver
@@ -69,6 +67,4 @@ package() {
make DESTDIR="$pkgdir/" install
}
-sha512sums="53c5e9442900bc4d8a1b45be5198c25a82e34b077d62ff11036f5f4bfc69906891a16dbc17d521fafe8738ef9363cbacd201e1848221cdd70c5c40a59c4ab03f graphite2-1.3.11.tar.gz
-4ef5414e6d554bb8d6ead435e38d061a073f350c313b7141158bb68332f5f57ca5250385875a387b828bb657964588e974143b96b5e11c2cd314871e7baddb88 graphite2-1.2.0-cmakepath.patch
-f6630138d67764b8240819125810544cf5ad89554b298de9762e5e05e85f9df719d957ac3f2e7a2c4e201cc6d58544f196d742b93fc2c5754db3c3ffe663492d cmake.patch"
+sha512sums="d0aed05b54445a9664435d5aef9d78fc07a89be23d18b7b1339d37412b09faca6da3dc1e72524e4b114724b76aa6f36934e8ab1a01bd0752e353efa075c9e643 graphite2-1.3.12.tar.gz"
diff --git a/main/graphite2/cmake.patch b/main/graphite2/cmake.patch
deleted file mode 100644
index ffafa17d4a..0000000000
--- a/main/graphite2/cmake.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- graphite2-1.2.0/src/CMakeLists.txt.orig 2012-11-09 17:48:04.908391335 +0800
-+++ graphite2-1.2.0/src/CMakeLists.txt 2012-11-09 17:48:48.647102280 +0800
-@@ -118,11 +118,7 @@
- if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
- target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
- else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
-- if (GRAPHITE2_ASAN)
-- target_link_libraries(graphite2 c gcc_s)
-- else (GRAPHITE2_ASAN)
-- target_link_libraries(graphite2 c gcc)
-- endif (GRAPHITE2_ASAN)
-+ target_link_libraries(graphite2 c gcc_s -lssp_nonshared)
- include(Graphite)
- nolib_test(stdc++ $<TARGET_SONAME_FILE:graphite2>)
- endif (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
-
diff --git a/main/graphite2/graphite2-1.2.0-cmakepath.patch b/main/graphite2/graphite2-1.2.0-cmakepath.patch
deleted file mode 100644
index daed0770fa..0000000000
--- a/main/graphite2/graphite2-1.2.0-cmakepath.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -urN graphite2-1.2.0.orig/src/CMakeLists.txt graphite2-1.2.0/src/CMakeLists.txt
---- graphite2-1.2.0.orig/src/CMakeLists.txt 2013-01-29 15:47:32.465841769 +0530
-+++ graphite2-1.2.0/src/CMakeLists.txt 2013-01-29 15:48:24.056843352 +0530
-@@ -136,4 +136,4 @@
-
-
- install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
--install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
-+install(EXPORT graphite2 DESTINATION lib${LIB_SUFFIX}/cmake/graphite2 NAMESPACE gr2_)