aboutsummaryrefslogtreecommitdiffstats
path: root/main/graphite2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-09-14 08:56:17 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-14 13:25:30 +0200
commit55612fdf79883b54b6a041c7bd96504046c1d519 (patch)
tree9e257cec46ad96993c227e76c75f6b7c6314c0e3 /main/graphite2
parent4041a223b7e7b9a7ab163406bc7f4b04a4a8fad3 (diff)
downloadaports-55612fdf79883b54b6a041c7bd96504046c1d519.tar.bz2
aports-55612fdf79883b54b6a041c7bd96504046c1d519.tar.xz
main/graphite2: upgrade to 1.3.2
Diffstat (limited to 'main/graphite2')
-rw-r--r--main/graphite2/APKBUILD23
-rw-r--r--main/graphite2/cmake.patch13
-rw-r--r--main/graphite2/graphite2-1.2.0-cmakepath.patch9
3 files changed, 38 insertions, 7 deletions
diff --git a/main/graphite2/APKBUILD b/main/graphite2/APKBUILD
index 69d18cd768..11e876f75e 100644
--- a/main/graphite2/APKBUILD
+++ b/main/graphite2/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=graphite2
-pkgver=1.2.4
-pkgrel=1
+pkgver=1.3.2
+pkgrel=0
pkgdesc="reimplementation of the SIL Graphite text processing engine"
url="http://projects.palaso.org/projects/graphitedev/"
arch="all"
@@ -12,7 +12,10 @@ depends_dev="freetype-dev"
makedepends="$depends_dev python cmake"
install=""
subpackages="$pkgname-dev"
-source="http://downloads.sourceforge.net/project/silgraphite/graphite2/graphite2-$pkgver.tgz"
+source="http://downloads.sourceforge.net/project/silgraphite/graphite2/graphite2-$pkgver.tgz
+ cmake.patch
+ graphite2-1.2.0-cmakepath.patch
+ "
_builddir="$srcdir"/graphite2-$pkgver
prepare() {
@@ -45,6 +48,12 @@ package() {
make DESTDIR="$pkgdir/" install
}
-md5sums="2ef839348fe28e3b923bf8cced440227 graphite2-1.2.4.tgz"
-sha256sums="4bc3d5168029bcc0aa00eb2c973269d29407be2796ff56f9c80e10736bd8b003 graphite2-1.2.4.tgz"
-sha512sums="fb4a7bfd5656233975ce339e4e155ccb4fd401b87e30440edab98739355596e41abf5dccf6487d53f6353840a7c87b8270ee33e79c6630cf13a25ac2cb2114de graphite2-1.2.4.tgz"
+md5sums="5a99dbd27c6a1a707d28bd38ea808562 graphite2-1.3.2.tgz
+741b8e8c91e5363beb5b1fe7e268f404 cmake.patch
+10df2e0a1ef4cee7edb9a6ad0c034b3c graphite2-1.2.0-cmakepath.patch"
+sha256sums="97af064ff07828f8724b5a9c27d63e2df5aef69a742f0f67cc3f68c3f15d3850 graphite2-1.3.2.tgz
+210e864979f4c49a9476d7e563013c39df40e5657bfd5f007f40897b9d636419 cmake.patch
+865b6edadffb97a983cc28dafb6827005dea153f5187db859180bc43a4500200 graphite2-1.2.0-cmakepath.patch"
+sha512sums="331cfd3df7187ff5a00bb161da9d811086ce8964650526affd70c2d9f25ab3a4c341cb7198d63e84f9b28ceb4ba7017b23194ce3fd2ad3787035e51df8c72d61 graphite2-1.3.2.tgz
+44dcff1e6c8c5e3df92eae8cab501c9605a1cd3e16b6cdce2e376d78fd08b26b7f6e037b7e5878099ba426a93572114169b5f64c4d2ae0bcbe223f1d28b00eb5 cmake.patch
+4ef5414e6d554bb8d6ead435e38d061a073f350c313b7141158bb68332f5f57ca5250385875a387b828bb657964588e974143b96b5e11c2cd314871e7baddb88 graphite2-1.2.0-cmakepath.patch"
diff --git a/main/graphite2/cmake.patch b/main/graphite2/cmake.patch
new file mode 100644
index 0000000000..41f1e51876
--- /dev/null
+++ b/main/graphite2/cmake.patch
@@ -0,0 +1,13 @@
+--- ./tests/CMakeLists.txt.orig
++++ ./tests/CMakeLists.txt
+@@ -58,7 +58,9 @@
+ LINKER_LANGUAGE C)
+ endif (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+
+-add_subdirectory(comparerenderer)
++if (GRAPHITE2_COMPARE_RENDERER)
++ add_subdirectory(comparerenderer)
++endif (GRAPHITE2_COMPARE_RENDERER)
+ add_subdirectory(endian)
+ add_subdirectory(bittwiddling)
+ if (NOT GRAPHITE2_NFILEFACE)
diff --git a/main/graphite2/graphite2-1.2.0-cmakepath.patch b/main/graphite2/graphite2-1.2.0-cmakepath.patch
new file mode 100644
index 0000000000..daed0770fa
--- /dev/null
+++ b/main/graphite2/graphite2-1.2.0-cmakepath.patch
@@ -0,0 +1,9 @@
+diff -urN graphite2-1.2.0.orig/src/CMakeLists.txt graphite2-1.2.0/src/CMakeLists.txt
+--- graphite2-1.2.0.orig/src/CMakeLists.txt 2013-01-29 15:47:32.465841769 +0530
++++ graphite2-1.2.0/src/CMakeLists.txt 2013-01-29 15:48:24.056843352 +0530
+@@ -136,4 +136,4 @@
+
+
+ install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
+-install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
++install(EXPORT graphite2 DESTINATION lib${LIB_SUFFIX}/cmake/graphite2 NAMESPACE gr2_)