aboutsummaryrefslogtreecommitdiffstats
path: root/main/graphite2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-24 08:59:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-24 08:59:02 +0000
commitaeb65ff53e14bceecc703545d6680e75f019664e (patch)
tree3ecb05b1cc27132742ffc948a5b3e1573e848c27 /main/graphite2
parent2617aebe4b063767ae360caa649d5f47484b0fad (diff)
downloadaports-aeb65ff53e14bceecc703545d6680e75f019664e.tar.bz2
aports-aeb65ff53e14bceecc703545d6680e75f019664e.tar.xz
main/graphite2: rebase old cmake patch
The patch is neeed to fix build on x86 and to fix install directory for cmake files so they are included in -dev subpackage.
Diffstat (limited to 'main/graphite2')
-rw-r--r--main/graphite2/APKBUILD6
-rw-r--r--main/graphite2/cmake.patch23
2 files changed, 27 insertions, 2 deletions
diff --git a/main/graphite2/APKBUILD b/main/graphite2/APKBUILD
index 249096b79c..031bd9663f 100644
--- a/main/graphite2/APKBUILD
+++ b/main/graphite2/APKBUILD
@@ -3,7 +3,7 @@
pkgname=graphite2
_realname=${pkgname/2/}
pkgver=1.3.12
-pkgrel=0
+pkgrel=1
pkgdesc="reimplementation of the SIL Graphite text processing engine"
url="http://graphite.sil.org/"
arch="all"
@@ -15,6 +15,7 @@ makedepends="$depends_dev cmake"
install=""
subpackages="$pkgname-static $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/silnrsi/$_realname/archive/$pkgver.tar.gz
+ cmake.patch
"
builddir="$srcdir"/$_realname-$pkgver
@@ -67,4 +68,5 @@ package() {
make DESTDIR="$pkgdir/" install
}
-sha512sums="d0aed05b54445a9664435d5aef9d78fc07a89be23d18b7b1339d37412b09faca6da3dc1e72524e4b114724b76aa6f36934e8ab1a01bd0752e353efa075c9e643 graphite2-1.3.12.tar.gz"
+sha512sums="d0aed05b54445a9664435d5aef9d78fc07a89be23d18b7b1339d37412b09faca6da3dc1e72524e4b114724b76aa6f36934e8ab1a01bd0752e353efa075c9e643 graphite2-1.3.12.tar.gz
+ed1edb48adcaf29fd630d039b9436510cd7116a1a2d976a17912068e5446b17c33c099d0a3ac890f138126d80c2e0f3b56b8a4a28999486705e77f519a16adb3 cmake.patch"
diff --git a/main/graphite2/cmake.patch b/main/graphite2/cmake.patch
new file mode 100644
index 0000000000..87f4dc9813
--- /dev/null
+++ b/main/graphite2/cmake.patch
@@ -0,0 +1,23 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 89a59af..b69e244 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -120,11 +120,7 @@ if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+ if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+ target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
+ else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+- if (GRAPHITE2_SANITIZERS)
+- target_link_libraries(graphite2 c gcc_s)
+- else ()
+- target_link_libraries(graphite2 c gcc)
+- endif ()
++ target_link_libraries(graphite2 c gcc_s -lssp_nonshared)
+ endif (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
+ include(Graphite)
+ if (BUILD_SHARED_LIBS)
+@@ -153,4 +149,4 @@ endif (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+
+
+ install(TARGETS graphite2 EXPORT graphite2 LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} PUBLIC_HEADER DESTINATION include/graphite2 RUNTIME DESTINATION bin)
+-install(EXPORT graphite2 DESTINATION share/graphite2 NAMESPACE gr2_)
++install(EXPORT graphite2 DESTINATION lib${LIB_SUFFIX}/cmake/graphite2 NAMESPACE gr2_)