aboutsummaryrefslogtreecommitdiffstats
path: root/main/hostapd/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-05 09:27:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-10 12:04:12 +0000
commit86ed9bddb82ee1c78369d3a0b0b125902c85fb74 (patch)
tree51652b4d38f6deaec37cd341485fa7110d512387 /main/hostapd/APKBUILD
parent9d0f1adc2a372eaa7a0a2bc6815317ffa1fa3bfd (diff)
downloadaports-86ed9bddb82ee1c78369d3a0b0b125902c85fb74.tar.bz2
aports-86ed9bddb82ee1c78369d3a0b0b125902c85fb74.tar.xz
main/hostapd: upgrade to 2.6 and use libressl
Diffstat (limited to 'main/hostapd/APKBUILD')
-rw-r--r--main/hostapd/APKBUILD46
1 files changed, 17 insertions, 29 deletions
diff --git a/main/hostapd/APKBUILD b/main/hostapd/APKBUILD
index 4bd35e67fe..a445780ca9 100644
--- a/main/hostapd/APKBUILD
+++ b/main/hostapd/APKBUILD
@@ -1,21 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hostapd
-pkgver=2.5
-pkgrel=3
+pkgver=2.6
+pkgrel=0
pkgdesc="daemon for wireless software access points"
url="http://hostap.epitest.fi/hostapd/"
arch="all"
license="custom"
depends=
-makedepends="openssl-dev libnl3-dev linux-headers"
+makedepends="libressl-dev libnl3-dev linux-headers"
install=
subpackages="$pkgname-doc"
patches="
- musl-fix-types.patch
CVE-2012-4445.patch
- 0001-EAP-pwd-peer-Fix-last-fragment-length-validation.patch
- 0001-EAP-pwd-server-Fix-last-fragment-length-validation.patch
- 0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
+ libressl-compat.patch
"
@@ -26,18 +23,18 @@ source="http://hostap.epitest.fi/releases/$pkgname-$pkgver.tar.gz
$pkgname.confd"
-_builddir="$srcdir"/$pkgname-$pkgver/hostapd
+builddir="$srcdir"/$pkgname-$pkgver/hostapd
prepare() {
- local conf="$_builddir/.config"
+ local conf="$builddir/.config"
- cd "$_builddir"/..
+ cd "$builddir"/..
for i in $patches; do
msg $i
patch -p1 -i "$srcdir"/$i || return 1
done
- cd "$_builddir"
+ cd "$builddir"
sed -i -e "s:/etc/hostapd:/etc/hostapd/hostapd:g" \
hostapd.conf
@@ -60,14 +57,14 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
make || return 1
msg "nt_password_hash"
- make nt_password_hash || return 1
+ make nt_password_hash || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
install -d "$pkgdir"/etc/hostapd
install hostapd.conf hostapd.accept hostapd.deny hostapd.eap_user \
hostapd.radius_clients hostapd.sim_db hostapd.wpa_psk \
@@ -88,27 +85,18 @@ package() {
|| return 1
}
-md5sums="69f9cec3f76d74f402864a43e4f8624f hostapd-2.5.tar.gz
-7568486221987c93041b4877eced7317 musl-fix-types.patch
+md5sums="eaa56dce9bd8f1d195eb62596eab34c7 hostapd-2.6.tar.gz
0d01d4641e0c33f79c1f4372613655bf CVE-2012-4445.patch
-ae911963ddb5426e4daeb080901f971d 0001-EAP-pwd-peer-Fix-last-fragment-length-validation.patch
-0bafbab0d6dbd17172b92e4e52a745a7 0001-EAP-pwd-server-Fix-last-fragment-length-validation.patch
-09372e008bac7534dc807b3740e35fe6 0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
+a4d1949ad55c3cb6c6f774a95ed6a3c8 libressl-compat.patch
29b561d4ee34dc22a8a0ae0bf1db5c45 hostapd.initd
c91382209042defa04e79d0ae841a29e hostapd.confd"
-sha256sums="8e272d954dc0d7026c264b79b15389ec2b2c555b32970de39f506b9f463ec74a hostapd-2.5.tar.gz
-f296013d432740478f24de7214d07ff897e6e38cbfd01a73a3158014f94fd771 musl-fix-types.patch
+sha256sums="01526b90c1d23bec4b0f052039cc4456c2fd19347b4d830d1d58a0a6aea7117d hostapd-2.6.tar.gz
06dc7df2159fb0604191f66d35164caa5927963eebe77b5f2c389bd7590e2a49 CVE-2012-4445.patch
-1ac039b13d88ff78ade418182cbef6e6c13f4ca9624fd4b3ce623b0442b43769 0001-EAP-pwd-peer-Fix-last-fragment-length-validation.patch
-4b6503e7ad4e049cb9566af7c220c451f65e35794962e239e908a1460c38a626 0001-EAP-pwd-server-Fix-last-fragment-length-validation.patch
-560bab824aa2a0bbeb549e2d3df49b23aed1b1dd12ca8685eae16cc24669b077 0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
+663bf347be3d95650be72ac1b465078bccf77cac879ddff05d3989448229c120 libressl-compat.patch
cae79127d088c047c1460d5b63eb67da1a830eb725a8c95e50070e516ad02800 hostapd.initd
6c14e88b14bb9a93d2dca69239d829f435e93180e621319aeed0f3987290dfba hostapd.confd"
-sha512sums="bbb0547c29f4925aff8639cae3291ed020c2a9d989dd267be831b2418880916d2ec69003e36ecc796c348476086397cca8f63c52633f91c11a9c2ab72e1c83c0 hostapd-2.5.tar.gz
-6ccdca29bc3a6b87d6e3f581c4f4725f0684bb88f39d46f875e9bdb0c41ee5b8be3b7908084c6631bffddece82cb2f2222e159d842944b6f2b7b639ef2de609c musl-fix-types.patch
+sha512sums="e60baaa092786250b8de9935f5417c7626f5d749210cce9f83d776b65c19fc92a8141f41923389f05c16295d482a15ae8d8b744f4667425040c99e3c2f5b1bda hostapd-2.6.tar.gz
619acce84516dead1e03e5da71657ea4c4b6f3ca8271574409773aeb316cbddc88095b50320804f457f001f4f3fe83053e660c008d8409f59bb4d3bfe058b601 CVE-2012-4445.patch
-c1a222b75cfbec77a88d83adfb2dbf93c040b5e3541e225aa218de1a8a11ed129946852247252fe993a0a6e8229293312a63b30824cd45ca7e81fb02d2df376f 0001-EAP-pwd-peer-Fix-last-fragment-length-validation.patch
-e29a0a3c88041c9a9d11801d311543c6c056b09d39798170e76cadeb407a3209d28f699a25cf58cc3484a60c420b2f5405cac56b1d03f8e7910469cb03971c28 0001-EAP-pwd-server-Fix-last-fragment-length-validation.patch
-e9ae7a6504cd6376f0fb24f79a21bc3996732451b474fe186769e1b098e47fdaedb08167fd90de900eb961e148577f24f24770d94050e60daa3a3f8de36a92c8 0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
+e6428a7fde025550e8d8252a04dd3a9009f95b6cab064c1f76bf4e5c321bc6acba9a21511e25f996fe98f6c9f1c057bc5af7aa9e6dd19e0bbc537b2be67d494f libressl-compat.patch
b54b7c6aa17e5cb86a9b354a516eb2dbefb544df18471339c61d82776de447011a2ac290bea1e6c8beae4b6cebefafb8174683ea42fb773e9e8fe6c679f33ba3 hostapd.initd
0882263bbd7c0b05bf51f51d66e11a23a0b8ca7da2a3b8a30166d2c5f044c0c134e6bccb1d02c9e81819ca8fb0c0fb55c7121a08fe7233ccaa73ff8ab9a238fe hostapd.confd"