aboutsummaryrefslogtreecommitdiffstats
path: root/main/icedtea-web
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-01 12:01:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-01 12:01:13 +0000
commit9e99574dd72e46ff68d4e839d14b16d45a6b9027 (patch)
treebd6aca273de27f984ef9a77e7f5e48874a685ca8 /main/icedtea-web
parent019b750721b088685257e6f182e5cc204332863e (diff)
downloadaports-9e99574dd72e46ff68d4e839d14b16d45a6b9027.tar.bz2
aports-9e99574dd72e46ff68d4e839d14b16d45a6b9027.tar.xz
main/icedtea-web: upgrade to 1.1.4
Diffstat (limited to 'main/icedtea-web')
-rw-r--r--main/icedtea-web/APKBUILD9
-rw-r--r--main/icedtea-web/const-char-np_getmimedescription.patch11
2 files changed, 17 insertions, 3 deletions
diff --git a/main/icedtea-web/APKBUILD b/main/icedtea-web/APKBUILD
index fe6f369510..84afcb1a22 100644
--- a/main/icedtea-web/APKBUILD
+++ b/main/icedtea-web/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=icedtea-web
-pkgver=1.1.3
+pkgver=1.1.4
pkgrel=0
pkgdesc="web integration packages for icedtea"
url="http://icedtea.classpath.org/wiki/IcedTea-Web"
@@ -12,7 +12,9 @@ depends_dev="xulrunner-dev openjdk6 gtk+-dev nspr-dev"
makedepends="tar zip $depends_dev"
install=""
subpackages="$pkgname-mozilla $pkgname-doc"
-source="http://icedtea.classpath.org/download/source/icedtea-web-$pkgver.tar.gz"
+source="http://icedtea.classpath.org/download/source/icedtea-web-$pkgver.tar.gz
+ const-char-np_getmimedescription.patch
+ "
CPU=`uname -m | sed -e 's/i.86/i386/g' -e 's/x86_64/amd64/g'`
@@ -56,4 +58,5 @@ mozilla() {
return 0
}
-md5sums="0e2e653c7436d81edcbc1d4255571ab6 icedtea-web-1.1.3.tar.gz"
+md5sums="1ed24b7e58da26471187dfae80b020b6 icedtea-web-1.1.4.tar.gz
+61a5afc7cbb205bc1cae624354266d68 const-char-np_getmimedescription.patch"
diff --git a/main/icedtea-web/const-char-np_getmimedescription.patch b/main/icedtea-web/const-char-np_getmimedescription.patch
new file mode 100644
index 0000000000..0194db1690
--- /dev/null
+++ b/main/icedtea-web/const-char-np_getmimedescription.patch
@@ -0,0 +1,11 @@
+--- ./plugin/icedteanp/IcedTeaNPPlugin.cc.orig
++++ ./plugin/icedteanp/IcedTeaNPPlugin.cc
+@@ -2262,7 +2262,7 @@
+
+ // Returns a string describing the MIME type that this plugin
+ // handles.
+-char*
++const char*
+ NP_GetMIMEDescription ()
+ {
+ PLUGIN_DEBUG ("NP_GetMIMEDescription\n");