aboutsummaryrefslogtreecommitdiffstats
path: root/main/jack
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-04 08:33:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-04 08:33:30 +0000
commitb667ca51aa608d3dabfe91c678f1415140d9870c (patch)
tree82f245387c2c7ed062c19e8a7d97d9774ee123cf /main/jack
parent64b6ed1cbd58cffcd09fa198e505207f3a7a4a20 (diff)
downloadaports-b667ca51aa608d3dabfe91c678f1415140d9870c.tar.bz2
aports-b667ca51aa608d3dabfe91c678f1415140d9870c.tar.xz
main/jack: moved from testing
Diffstat (limited to 'main/jack')
-rw-r--r--main/jack/APKBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/main/jack/APKBUILD b/main/jack/APKBUILD
new file mode 100644
index 0000000000..f0bfa1c403
--- /dev/null
+++ b/main/jack/APKBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=jack
+pkgver=1.9.8
+pkgrel=0
+pkgdesc="The Jack Audio Connection Kit"
+url="http://www.jackaudio.org"
+arch="all"
+license="GPLv2 GPLv2+ LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev alsa-lib-dev dbus-dev expat-dev libsamplerate-dev
+ libsndfile-dev ncurses-dev readline-dev python"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-dbus $pkgname-example-clients:_clients"
+source="http://www.grame.fr/~letz/jack-$pkgver.tgz"
+
+_builddir="$srcdir"/jack-$pkgver/jack-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ export PREFIX=/usr
+ ./waf configure \
+ -j1 \
+ --mandir=/share/man/man1 \
+ --libdir=/lib \
+ --dbus \
+ --alsa \
+ --classic \
+ || return 1
+
+
+ ./waf build -j${JOBS:-2} -v || return 1
+}
+
+package() {
+ cd "$_builddir"
+ ./waf --destdir="$pkgdir" install || return 1
+}
+
+dbus() {
+ pkgdesc="Jack D-Bus launcher"
+ mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/bin/jackdbus "$subpkgdir"/usr/bin/ || return 1
+ mv "$pkgdir"/usr/share/dbus* "$subpkgdir"/usr/share/|| return 1
+}
+
+_clients() {
+ pkgdesc="Example clients that use Jack"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/*_* "$subpkgdir"/usr/bin/
+}
+
+md5sums="1dd2ff054cab79dfc11d134756f27165 jack-1.9.8.tgz"