aboutsummaryrefslogtreecommitdiffstats
path: root/main/libraw
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-12 09:57:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-12 09:57:21 +0000
commit30cadb0b12ee5b2442659e0304a96a1786d1584d (patch)
tree8ff6634134d3833194861906ecee9767bf6737ec /main/libraw
parentb2273efae7cb2609fc2d1da622a95fd82678058c (diff)
downloadaports-30cadb0b12ee5b2442659e0304a96a1786d1584d.tar.bz2
aports-30cadb0b12ee5b2442659e0304a96a1786d1584d.tar.xz
main/libraw: moved from testing
Diffstat (limited to 'main/libraw')
-rw-r--r--main/libraw/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/libraw/APKBUILD b/main/libraw/APKBUILD
new file mode 100644
index 0000000000..d741b7384c
--- /dev/null
+++ b/main/libraw/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libraw
+pkgver=0.13.2
+pkgrel=0
+pkgdesc="Library for reading RAW files obtained from digital photo cameras"
+url="http://www.libraw.org/"
+arch="all"
+license="CDDL LGPL custom"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.libraw.org/data/LibRaw-$pkgver.tar.gz"
+
+_builddir="$srcdir"/LibRaw-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) patch -p1 -i "$srcdir"/$i || return 1
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make lib/libraw.a lib/libraw_r.a
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="e92895f6b8f975be63f59448c1b8a79b LibRaw-0.13.2.tar.gz"