aboutsummaryrefslogtreecommitdiffstats
path: root/main/libsearpc
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-31 11:50:35 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-31 11:50:35 +0100
commitbd40d543bcea6700c99518d1dda8e9c82e3449bf (patch)
tree68691b8f8eb470855c1655b7792599a815db5b4d /main/libsearpc
parentc3e2c12d30f48a88fbc9b4aa98a0861ebb06d052 (diff)
downloadaports-bd40d543bcea6700c99518d1dda8e9c82e3449bf.tar.bz2
aports-bd40d543bcea6700c99518d1dda8e9c82e3449bf.tar.xz
testing/seafile: move seafile and deps to main
Diffstat (limited to 'main/libsearpc')
-rw-r--r--main/libsearpc/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/main/libsearpc/APKBUILD b/main/libsearpc/APKBUILD
new file mode 100644
index 0000000000..ae29d8d7fd
--- /dev/null
+++ b/main/libsearpc/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsearpc
+pkgver=3.0.6
+pkgrel=0
+pkgdesc="A simple and easy-to-use C language RPC framework"
+url="https://github.com/haiwen/libsearpc/"
+arch="all"
+license="LGPL2.1"
+makedepends="autoconf automake bash glib-dev jansson-dev libtool python-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/haiwen/libsearpc/archive/v3.0-latest.tar.gz"
+subpackages="$pkgname-dev py-$pkgname:py"
+
+_builddir="${srcdir}"/${pkgname}-3.0-latest
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+ rm "${pkgdir}"/usr/lib/libsearpc.la
+ echo ${pkgdir}/usr/lib/pkgconfig/libsearpc.pc
+ sed -i -e 's/(DESTDIR)//' "${pkgdir}"/usr/lib/pkgconfig/libsearpc.pc
+ sed -i -e 's/prefix=.*/prefix=\/usr/' "${pkgdir}"/usr/lib/pkgconfig/libsearpc.pc
+}
+
+py() {
+ arch="noarch"
+ cd "$_builddir"
+ pkgdesc="$pkgname python bindings"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+md5sums="32a6eaafe16d8c0c0e320b4a08a4d8f6 libsearpc-3.0.6.tar.gz"
+sha256sums="56313771e0ad7dc075c4590b6a75daeb3939937b21716d82c91be2612133b8cd libsearpc-3.0.6.tar.gz"
+sha512sums="f5706d5490eb6abd05a25963ae204b358e7ebdcf153ab4bfe76819fd4538f1a957d7eaf84d8e60e076d978f9c1605adb2e6ec7ded55950c551304eb7665b15e8 libsearpc-3.0.6.tar.gz"