aboutsummaryrefslogtreecommitdiffstats
path: root/main/libtheora
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-01 00:24:52 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-01 00:37:40 +0200
commit2383bcbb6c87ee1d59970dcc57cec9c067858511 (patch)
tree50438ba0c5c0ad0815fe9803f8d22df98f861f6b /main/libtheora
parent1e2662d505a9376797c5147803cabf200c89f069 (diff)
downloadaports-2383bcbb6c87ee1d59970dcc57cec9c067858511.tar.bz2
aports-2383bcbb6c87ee1d59970dcc57cec9c067858511.tar.xz
main/libtheora: modernize abuild and run tests
Diffstat (limited to 'main/libtheora')
-rw-r--r--main/libtheora/APKBUILD35
1 files changed, 22 insertions, 13 deletions
diff --git a/main/libtheora/APKBUILD b/main/libtheora/APKBUILD
index 57dd01c7ac..6f43fc2a6d 100644
--- a/main/libtheora/APKBUILD
+++ b/main/libtheora/APKBUILD
@@ -7,7 +7,6 @@ url="http://www.xiph.org"
arch="all"
license="custom"
subpackages="$pkgname-dev $pkgname-doc $pkgname-examples"
-depends=
depends_dev="libogg-dev"
makedepends="libvorbis-dev libogg-dev sdl-dev autoconf automake libtool
linux-headers"
@@ -18,36 +17,45 @@ source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
fix-mmx.patch
automake.patch
"
+builddir="$srcdir/$pkgname-$pkgver"
-builddir="$srcdir"/libtheora-$pkgver
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
- sed -i 's/png_\(sizeof\)/\1/g' examples/png2theora.c || return 1
- libtoolize --force && aclocal -I m4 && autoconf --force \
- && automake --force --add-missing || return 1
+
+ sed -i 's/png_\(sizeof\)/\1/g' examples/png2theora.c
+
+ libtoolize --force
+ aclocal -I m4
+ autoconf --force
+ automake --force --add-missing
}
build() {
cd "$builddir"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--enable-shared \
- --disable-static \
- || return 1
+ --disable-static
+ make -C lib
+ make
+}
- cd lib && make || return 1
- cd ..
- make || return 1
+check() {
+ cd "$builddir"
+
+ make check
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
- install -m755 -d ""$pkgdir"/usr/share/licenses/$pkgname"
+ make -j1 DESTDIR="$pkgdir" install
+
+ install -m755 -d "$pkgdir"/usr/share/licenses/$pkgname
install -m644 LICENSE COPYING "$pkgdir"/usr/share/licenses/$pkgname/
}
@@ -55,6 +63,7 @@ examples() {
pkgdesc="Example applications for libtheora"
cd "$builddir"/examples/.libs
+
install -d "$subpkgdir"/usr/bin
install -m755 dump_psnr player_example dump_video encoder_example \
"$subpkgdir"/usr/bin/