aboutsummaryrefslogtreecommitdiffstats
path: root/main/libvdpau
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-05 19:16:28 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:53:39 +0000
commitc140c5b210f10c49112ca5df63b1ececeb6da9f7 (patch)
tree6d5f74231afe688d2a4387e01da2a1dc32e62ced /main/libvdpau
parente1005a70f16d73141f506f542323266ac80375fc (diff)
downloadaports-c140c5b210f10c49112ca5df63b1ececeb6da9f7.tar.bz2
aports-c140c5b210f10c49112ca5df63b1ececeb6da9f7.tar.xz
main/libvdpau: modernise, add test suite, fix description
Diffstat (limited to 'main/libvdpau')
-rw-r--r--main/libvdpau/APKBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/main/libvdpau/APKBUILD b/main/libvdpau/APKBUILD
index ca055421e0..08592c83f8 100644
--- a/main/libvdpau/APKBUILD
+++ b/main/libvdpau/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libvdpau
pkgver=1.1.1
-pkgrel=0
-pkgdesc="Nvidia VDPAU library"
+pkgrel=1
+pkgdesc="Hardware-accelerated video playback library"
url="http://cgit.freedesktop.org/~aplattner/libvdpau"
arch="all"
license="custom"
@@ -13,15 +13,8 @@ install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://people.freedesktop.org/~aplattner/vdpau/${pkgname}-${pkgver}.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- # apply patches here
-}
-
build() {
- cd "$_builddir"
+ cd "$builddir"
LIBS="-lX11" \
./configure \
--build=$CBUILD \
@@ -29,16 +22,20 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- || return 1
- make || return 1
+ --infodir=/usr/share/info
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
}
md5sums="ac8b21012035c04fd1ec8a9ae6934264 libvdpau-1.1.1.tar.gz"