aboutsummaryrefslogtreecommitdiffstats
path: root/main/logcheck/APKBUILD
diff options
context:
space:
mode:
authorDuane Hughes <duanejevon@gmail.com>2011-03-22 08:30:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-22 21:03:30 +0000
commit019aab029adea34f90f2811556b8df162c3e7b46 (patch)
treeae83fe79babb2df7f6a7d658afe1fde6bbd5ef67 /main/logcheck/APKBUILD
parentacdd8885dd810ddcea0f0dc77b9cb34e66c97709 (diff)
downloadaports-019aab029adea34f90f2811556b8df162c3e7b46.tar.bz2
aports-019aab029adea34f90f2811556b8df162c3e7b46.tar.xz
main/{liblockfile|logcheck|lockfile-progs}: moving to main branch
verified operation, moving to main repo
Diffstat (limited to 'main/logcheck/APKBUILD')
-rw-r--r--main/logcheck/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/logcheck/APKBUILD b/main/logcheck/APKBUILD
new file mode 100644
index 0000000000..e437f2c788
--- /dev/null
+++ b/main/logcheck/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Duane Hughes <duanejevon@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=logcheck
+pkgver=1.3.13
+pkgrel=0
+pkgdesc="Bash scripts used to monitor system log files for anomalies"
+url="http://packages.debian.org/source/sid/logcheck"
+arch="noarch"
+license="GPL"
+depends="lockfile-progs"
+makedepends=
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages="$pkgname-doc"
+source="http://ftp.debian.org/debian/pool/main/l/logcheck/${pkgname}_$pkgver.tar.gz
+ logcheck.cron.d
+ "
+
+_builddir="$srcdir"/$pkgname
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ install -D -m 644 "$srcdir"/logcheck.cron.d "$pkgdir"/etc/logcheck/logcheck.cron.sample
+ install -d "$pkgdir"/usr/share/man
+ cp -a "$_builddir"/docs/* "$pkgdir"/usr/share/man
+}
+
+md5sums="e2ff14f522bf2e30d5947c85fed44973 logcheck_1.3.13.tar.gz
+89be84c722a958659df9a937826cbdc2 logcheck.cron.d"