aboutsummaryrefslogtreecommitdiffstats
path: root/main/logcheck
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-04 06:26:28 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-04 06:42:11 +0000
commit7eda8fd8ec0b6880ec5db2200f0d2c519425b41f (patch)
treed30b7d09c3bcd1c3e6eca651d4b73d4961173510 /main/logcheck
parentfc7827245af89c2a63cc92fd9b6cae8e02f1b637 (diff)
downloadaports-7eda8fd8ec0b6880ec5db2200f0d2c519425b41f.tar.bz2
aports-7eda8fd8ec0b6880ec5db2200f0d2c519425b41f.tar.xz
main/logcheck: upgrade to 1.3.18, modernize APKBUILD
Diffstat (limited to 'main/logcheck')
-rw-r--r--main/logcheck/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/logcheck/APKBUILD b/main/logcheck/APKBUILD
index 8b4ae05a74..f606e95b0e 100644
--- a/main/logcheck/APKBUILD
+++ b/main/logcheck/APKBUILD
@@ -8,8 +8,8 @@ url="http://packages.debian.org/source/sid/logcheck"
arch="noarch"
license="GPL"
depends="lockfile-progs"
-makedepends=
install="$pkgname.pre-install"
+options="!check"
subpackages="$pkgname-doc"
pkgusers="logcheck"
source="http://ftp.debian.org/debian/pool/main/l/logcheck/${pkgname}_$pkgver.tar.xz
@@ -17,6 +17,11 @@ source="http://ftp.debian.org/debian/pool/main/l/logcheck/${pkgname}_$pkgver.tar
builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ return 0
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install