aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-ossl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-11-06 08:25:46 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-11-06 08:25:46 +0200
commitee319a1187cc80431002ca41efecca3b2d0092c2 (patch)
treecbff3983ee99cd830766b121e2874f3258bc1a7a /main/lua-ossl
parent635d2105ffec82b9a310a0d258775bbca6da82b9 (diff)
downloadaports-ee319a1187cc80431002ca41efecca3b2d0092c2.tar.bz2
aports-ee319a1187cc80431002ca41efecca3b2d0092c2.tar.xz
main/lua-ossl: upgrade to 20141028-0
Diffstat (limited to 'main/lua-ossl')
-rw-r--r--main/lua-ossl/0001-parse-CRLs-from-PEM-and-DER-formats.patch61
-rw-r--r--main/lua-ossl/APKBUILD24
2 files changed, 10 insertions, 75 deletions
diff --git a/main/lua-ossl/0001-parse-CRLs-from-PEM-and-DER-formats.patch b/main/lua-ossl/0001-parse-CRLs-from-PEM-and-DER-formats.patch
deleted file mode 100644
index 94539b2045..0000000000
--- a/main/lua-ossl/0001-parse-CRLs-from-PEM-and-DER-formats.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From fd6efb22e98d51b441b9b4d9e440c099ba07ca4a Mon Sep 17 00:00:00 2001
-From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
-Date: Fri, 5 Sep 2014 10:38:43 +0300
-Subject: [PATCH] parse CRLs from PEM and DER formats
-
----
- src/openssl.c | 33 ++++++++++++++++++++++++++++++---
- 1 file changed, 30 insertions(+), 3 deletions(-)
-
-diff --git a/src/openssl.c b/src/openssl.c
-index 757bbf0..9845bcc 100644
---- a/src/openssl.c
-+++ b/src/openssl.c
-@@ -3070,14 +3070,41 @@ int luaopen__openssl_x509_csr(lua_State *L) {
- * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * */
-
- static int xx_new(lua_State *L) {
-+ const char *data;
-+ size_t len;
- X509_CRL **ud;
-
-+ lua_settop(L, 2);
-+
- ud = prepsimple(L, X509_CRL_CLASS);
-
-- if (!(*ud = X509_CRL_new()))
-- return throwssl(L, "x509.crl.new");
-+ if ((data = luaL_optlstring(L, 1, NULL, &len))) {
-+ int type = optencoding(L, 2, "*", X509_ANY|X509_PEM|X509_DER);
-+ BIO *tmp;
-+ int ok = 0;
-+
-+ if (!(tmp = BIO_new_mem_buf((char *)data, len)))
-+ return throwssl(L, "x509.crl.new");
-+
-+ if (type == X509_PEM || type == X509_ANY) {
-+ ok = !!(*ud = PEM_read_bio_X509_CRL(tmp, NULL, 0, "")); /* no password */
-+ }
-+
-+ if (!ok && (type == X509_DER || type == X509_ANY)) {
-+ ok = !!(*ud = d2i_X509_CRL_bio(tmp, NULL));
-+ }
-
-- X509_gmtime_adj(X509_CRL_get_lastUpdate(*ud), 0);
-+ BIO_free(tmp);
-+
-+ if (!ok)
-+ return throwssl(L, "x509.crl.new");
-+ }
-+ else {
-+ if (!(*ud = X509_CRL_new()))
-+ return throwssl(L, "x509.crl.new");
-+
-+ X509_gmtime_adj(X509_CRL_get_lastUpdate(*ud), 0);
-+ }
-
- return 1;
- } /* xx_new() */
---
-1.8.3.1
-
diff --git a/main/lua-ossl/APKBUILD b/main/lua-ossl/APKBUILD
index 79e897b075..d8b5ad1770 100644
--- a/main/lua-ossl/APKBUILD
+++ b/main/lua-ossl/APKBUILD
@@ -3,9 +3,9 @@
_luaversions="5.1 5.2"
pkgname=lua-ossl
-pkgver=20140718
+pkgver=20141028
_ver=${pkgver%_git*}
-pkgrel=2
+pkgrel=0
pkgdesc="comprehensive OpenSSL Lua module"
url="http://25thandclement.com/~william/projects/luaossl.html"
arch="all"
@@ -22,12 +22,11 @@ for _v in $_luaversions; do
subpackages="$subpackages lua$_v-ossl:split_${_v/./_}"
done
-source="luaossl-$_ver.tar.gz::https://github.com/wahern/luaossl/archive/rel-$_ver.tar.gz
+source="luaossl-$_ver.tar.gz::https://github.com/wahern/luaossl/archive/deb-$_ver-0.tar.gz
musl-fixes.patch
- 0001-parse-CRLs-from-PEM-and-DER-formats.patch
"
-_builddir="$srcdir"/luaossl-rel-$_ver
+_builddir="$srcdir"/luaossl-deb-$_ver-0
prepare() {
local i
cd "$_builddir"
@@ -71,12 +70,9 @@ for _v in $_luaversions; do
eval "split_${_v/./_}() { _split $_v; }"
done
-md5sums="38d7c4527580e03335299349be4d70bc luaossl-20140718.tar.gz
-7d03f360ebc62b60279ff0f2066ed6f6 musl-fixes.patch
-0ec967f53f6abaac1c9143338811e160 0001-parse-CRLs-from-PEM-and-DER-formats.patch"
-sha256sums="5711dc079ecb2c01b6a5eb753839efbb599ee92ce0bd971ea55fe696d0bb39e0 luaossl-20140718.tar.gz
-49694f9ab7f7a90074471d8e55580f13ff8fc6f7a158a5793f8d55df11147c0e musl-fixes.patch
-227756f93b4db793dbbfbd05f576531a032c4c3e6356e91f774e7663101a16c9 0001-parse-CRLs-from-PEM-and-DER-formats.patch"
-sha512sums="5944ff745e08472e2be6b95c1fabdaaed46aeae8221d4e59fdbe8b8a4ee70368eb1d9cd39f619274a20151a46f5882445c89f69fc83cc54d812c01908ba1123d luaossl-20140718.tar.gz
-370467081c87c0e4b0c96a72ff81918d3d492dfa90578b34f51004461d9a983ffd486accb44471a34d092b1a08743ad60462c6937096f80f72a39a335ccd81be musl-fixes.patch
-d01c2b5efc95d6ddd79456ce6bfcce366b2863a10dfaed48b7dbe6f881da318b2e69a93ca64bbdba6a1dadcabbbefd398569c37364e7f87331d307eed311d55c 0001-parse-CRLs-from-PEM-and-DER-formats.patch"
+md5sums="0f90d964b9a058b1ee7d56be545d54ab luaossl-20141028.tar.gz
+7d03f360ebc62b60279ff0f2066ed6f6 musl-fixes.patch"
+sha256sums="f4b64936a8ba1792fed14331cf7856646700833e5276a096ef5c6410cd9393c2 luaossl-20141028.tar.gz
+49694f9ab7f7a90074471d8e55580f13ff8fc6f7a158a5793f8d55df11147c0e musl-fixes.patch"
+sha512sums="8edcb77becb4994c8d2ef0144a45eafcfccf7dca0d78940cf35a4bdbb2daec4be5c4a3a758e2a8ead2e6c395795a44f5b5061f05d1e2149600d48fec09bdf3fc luaossl-20141028.tar.gz
+370467081c87c0e4b0c96a72ff81918d3d492dfa90578b34f51004461d9a983ffd486accb44471a34d092b1a08743ad60462c6937096f80f72a39a335ccd81be musl-fixes.patch"