aboutsummaryrefslogtreecommitdiffstats
path: root/main/meson
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-23 09:24:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 21:12:11 +0000
commit3a6d0d39f1fc86fb5c3efe20b86255c4cd353444 (patch)
treeedc709282b8f72a1d9cee472ff8630c6eeadff49 /main/meson
parent02a14fa129c14eed79f97e34699178db89a9e2bd (diff)
downloadaports-3a6d0d39f1fc86fb5c3efe20b86255c4cd353444.tar.bz2
aports-3a6d0d39f1fc86fb5c3efe20b86255c4cd353444.tar.xz
main/meson: improve abuild
Diffstat (limited to 'main/meson')
-rw-r--r--main/meson/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/meson/APKBUILD b/main/meson/APKBUILD
index b49c85621b..c2d3f62266 100644
--- a/main/meson/APKBUILD
+++ b/main/meson/APKBUILD
@@ -3,15 +3,14 @@
pkgname=meson
pkgver=0.46.0
pkgrel=0
-pkgdesc="Build system meant to be both extremely fast and as user friendly as possible"
-url="http://mesonbuild.com/"
+pkgdesc="Fast and user friendly build system"
+url="http://mesonbuild.com"
arch="noarch"
license="Apache-2.0"
-depends="python3 ninja"
+depends="ninja python3"
makedepends="python3-dev"
subpackages="$pkgname-doc"
-source="https://github.com/mesonbuild/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://github.com/mesonbuild/meson/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
build() {
cd "$builddir"