aboutsummaryrefslogtreecommitdiffstats
path: root/main/mosquitto
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-09-27 11:32:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-27 11:32:44 +0000
commit1010882df397e3c8f889b1f5bc658e870d5f52a6 (patch)
tree878ae6d7dcb99ffa48214642c04ee616be3c348f /main/mosquitto
parent609fbb0235cf6440f5d502885c4e0531c835aed7 (diff)
downloadaports-1010882df397e3c8f889b1f5bc658e870d5f52a6.tar.bz2
aports-1010882df397e3c8f889b1f5bc658e870d5f52a6.tar.xz
main/mosquitto: security upgrade to 1.5.3 (CVE-2018-12543)
Diffstat (limited to 'main/mosquitto')
-rw-r--r--main/mosquitto/APKBUILD9
-rw-r--r--main/mosquitto/config.patch29
2 files changed, 16 insertions, 22 deletions
diff --git a/main/mosquitto/APKBUILD b/main/mosquitto/APKBUILD
index ad9a11cb67..1d23ba9194 100644
--- a/main/mosquitto/APKBUILD
+++ b/main/mosquitto/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Pedro Filipe <xpecex@outlook.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mosquitto
-pkgver=1.5.2
+pkgver=1.5.3
pkgrel=0
pkgdesc="An Open Source MQTT v3.1 Broker"
url="http://mosquitto.org/"
@@ -23,6 +23,8 @@ source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
+# 1.5.3-r0:
+# - CVE-2018-12543
# 1.4.15-r0:
# - CVE-2017-7652
# - CVE-2017-7651
@@ -54,7 +56,6 @@ build() {
check() {
cd "$builddir"
-
make test
}
@@ -87,7 +88,7 @@ clients() {
mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
}
-sha512sums="25b6df1214c5907ca868413dfd9fcd0079ff8b727b66940a79c714a07a82a71afd88fe9a39384fe9a13203f5d901e8d5e2b7ea89ff2ab7d6cc304ce18a5429c1 mosquitto-1.5.2.tar.gz
+sha512sums="8aa4f85914316c2dc08908a649779946ab33b23ea669c6f7eed0d8a1af7ae26381cfe1a50c32d220658f8693ef6a86045690824af4b7ca0271426ff3455e7796 mosquitto-1.5.3.tar.gz
53859b628f965b77f6e47910c0ceba2f2737b815131ed800dc64a80419e434d25b5ba0938ae645882e9aa5d475d4940c7d35cc6d56f54bc4937a66b32d7db4ad libressl.patch
-d5442373ae6ae8bc83eee59b425fbd76e80f905b9fd2bd2ed2a37a7e156fe95a9cf477c9c4dac0975c5fd90e70884de6fb8a16aefcd37b239199d5deae50b7d2 config.patch
+fb000f9fa1ef94cbf3811a23b5692c0c8f9e2df945959cef6005462715e99d6f75cf6b31bd496271ffc17634024aed986771a73962fef865c0d386f6c194fb33 config.patch
16f96d8f7f3a8b06e2b2e04d42d7e0d89a931b52277fc017e4802f7a3bc85aff4dd290b1a0c40382ea8f5568d0ceb7319c031d9be916f346d805231a002b0433 mosquitto.initd"
diff --git a/main/mosquitto/config.patch b/main/mosquitto/config.patch
index a88d35366b..a070427ddb 100644
--- a/main/mosquitto/config.patch
+++ b/main/mosquitto/config.patch
@@ -1,15 +1,17 @@
---- ./config.mk.orig
-+++ ./config.mk
-@@ -26,7 +26,7 @@
+diff --git a/config.mk b/config.mk
+index 46ffb6d..4e7b31d 100644
+--- a/config.mk
++++ b/config.mk
+@@ -26,7 +26,7 @@ WITH_TLS:=yes
# Comment out to disable TLS/PSK support in the broker and client. Requires
# WITH_TLS=yes.
# This must be disabled if using openssl < 1.0.
-WITH_TLS_PSK:=yes
+WITH_TLS_PSK:=no
- # Comment out to disable client client threading support.
+ # Comment out to disable client threading support.
WITH_THREADING:=yes
-@@ -46,7 +46,7 @@
+@@ -46,7 +46,7 @@ WITH_PERSISTENCE:=yes
# Comment out to remove memory tracking support from the broker. If disabled,
# mosquitto won't track heap memory usage nor export '$SYS/broker/heap/current
# size', but will use slightly less memory and CPU time.
@@ -18,7 +20,7 @@
# Compile with database upgrading support? If disabled, mosquitto won't
# automatically upgrade old database versions.
-@@ -65,7 +65,7 @@
+@@ -69,7 +69,7 @@ WITH_SRV:=no
WITH_UUID:=yes
# Build with websockets support on the broker.
@@ -27,20 +29,11 @@
# Use elliptic keys in broker
WITH_EC:=yes
-@@ -78,6 +78,7 @@
+@@ -88,6 +88,7 @@ WITH_STATIC_LIBRARIES:=no
# Build with async dns lookup support for bridges (temporary). Requires glibc.
#WITH_ADNS:=yes
+WITH_ADNS=no
- # =============================================================================
- # End of user configuration
-@@ -249,7 +250,7 @@
- endif
-
- INSTALL?=install
--prefix=/usr/local
-+prefix=/usr
- mandir=${prefix}/share/man
- localedir=${prefix}/share/locale
- STRIP?=strip
+ # Build with epoll support.
+ WITH_EPOLL:=yes