aboutsummaryrefslogtreecommitdiffstats
path: root/main/mosquitto
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-28 19:11:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-28 19:12:23 +0000
commit63f7805be085d80b54a09debdf06786dac559cc4 (patch)
treeb667e347266bef48a0a9b639901c3d9ae16ee283 /main/mosquitto
parent7bf9f57d51e647666d9e74ff3ec127b7aa80c07b (diff)
downloadaports-63f7805be085d80b54a09debdf06786dac559cc4.tar.bz2
aports-63f7805be085d80b54a09debdf06786dac559cc4.tar.xz
main/mosquitto: fix flush patch and checksum
Diffstat (limited to 'main/mosquitto')
-rw-r--r--main/mosquitto/APKBUILD2
-rw-r--r--main/mosquitto/mosquitto_passwd-flush.patch19
2 files changed, 1 insertions, 20 deletions
diff --git a/main/mosquitto/APKBUILD b/main/mosquitto/APKBUILD
index 301cb85681..f9fb6ccc4c 100644
--- a/main/mosquitto/APKBUILD
+++ b/main/mosquitto/APKBUILD
@@ -90,5 +90,5 @@ clients() {
sha512sums="36b06547553cf28af3ca9b728c42fc27e849c4ae84d7964572d430233ab26e2b59eee2a215ac23ddf2d0bef419e7c70e64e2a22c397fadb3e0677314d03f1100 mosquitto-1.4.15.tar.gz
53859b628f965b77f6e47910c0ceba2f2737b815131ed800dc64a80419e434d25b5ba0938ae645882e9aa5d475d4940c7d35cc6d56f54bc4937a66b32d7db4ad libressl.patch
d5442373ae6ae8bc83eee59b425fbd76e80f905b9fd2bd2ed2a37a7e156fe95a9cf477c9c4dac0975c5fd90e70884de6fb8a16aefcd37b239199d5deae50b7d2 config.patch
-f61ece1f708f2f56a9e8e77f960b61ad42141a1cd8a12b679d72b53fec4889861a468c2ce541190ef2467fbe53816daef11b11a4e7fcfc4da7ee3a7400e559b0 mosquitto_passwd-flush.patch
+fa38a60cce4444de2b5c017513c978ef9085b3174f2ea901028c862637c1b2f3c02eb467eb8f7ed61b48d5f741f217352a0ae91e35913e6127ca1d910b9517b0 mosquitto_passwd-flush.patch
16f96d8f7f3a8b06e2b2e04d42d7e0d89a931b52277fc017e4802f7a3bc85aff4dd290b1a0c40382ea8f5568d0ceb7319c031d9be916f346d805231a002b0433 mosquitto.initd"
diff --git a/main/mosquitto/mosquitto_passwd-flush.patch b/main/mosquitto/mosquitto_passwd-flush.patch
index b2bc854578..19288992e1 100644
--- a/main/mosquitto/mosquitto_passwd-flush.patch
+++ b/main/mosquitto/mosquitto_passwd-flush.patch
@@ -1,22 +1,3 @@
-diff --git a/config.mk b/config.mk
-index 41c7af6..19d98fb 100644
---- a/config.mk
-+++ b/config.mk
-@@ -21,12 +21,12 @@
- # Disabling this will also mean that passwords must be stored in plain text. It
- # is strongly recommended that you only disable WITH_TLS if you are not using
- # password authentication at all.
--WITH_TLS:=yes
-+#WITH_TLS:=yes
-
- # Comment out to disable TLS/PSK support in the broker and client. Requires
- # WITH_TLS=yes.
- # This must be disabled if using openssl < 1.0.
--WITH_TLS_PSK:=yes
-+#WITH_TLS_PSK:=yes
-
- # Comment out to disable client client threading support.
- WITH_THREADING:=yes
diff --git a/src/mosquitto_passwd.c b/src/mosquitto_passwd.c
index ea8c315..5b303c1 100644
--- a/src/mosquitto_passwd.c