aboutsummaryrefslogtreecommitdiffstats
path: root/main/musl/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-06-21 11:29:38 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-06-21 11:29:38 +0300
commitd985d2b50a41eb5f9ba682f4afe72ac2c59b53e8 (patch)
tree767a67cd54db1beb8549106f1b729699411df431 /main/musl/APKBUILD
parent6b899d49bd1d15c8390bd53e710da0b26a36218e (diff)
downloadaports-d985d2b50a41eb5f9ba682f4afe72ac2c59b53e8.tar.bz2
aports-d985d2b50a41eb5f9ba682f4afe72ac2c59b53e8.tar.xz
main/musl: cherry-pick upstream fixes
Diffstat (limited to 'main/musl/APKBUILD')
-rw-r--r--main/musl/APKBUILD18
1 files changed, 17 insertions, 1 deletions
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index a2d82e75f6..6317ea7657 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=1.1.16
-pkgrel=12
+pkgrel=13
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -58,6 +58,14 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
0039-fix-iconv-conversions-to-legacy-8bit-encodings.patch
0040-fix-fchown-fallback-on-arches-without-chown-2.patch
0041-towupper-towlower-fast-path-for-ascii-chars.patch
+ 0042-fix-glob-failure-to-match-plain-to-root-directory.patch
+ 0043-catopen-set-errno-to-EOPNOTSUPP.patch
+ 0044-getdate-correctly-specify-error-number.patch
+ 0045-handle-mremap-failure-in-realloc-of-mmap-serviced-al.patch
+ 0046-handle-localtime-errors-in-ctime.patch
+ 0047-set-errno-when-getpw-_r-getgr-_r-and-getspnam_r-fail.patch
+ 0048-handle-errors-from-localtime_r-in-ctime_r.patch
+ 0049-fix-iconv-conversions-for-iso88592-iso885916.patch
1000-implement-strftime-GNU-extension-padding-specifiers-.patch
ldconfig
@@ -223,6 +231,14 @@ be15b749bec54ef342afa252d7fe46a644d2fcb77336719e57db613036d5f65531a03b17c9c5f92a
0f0cea53dba8a9ecbd493ce94fe17a22f814f3a35dbbb0a40749b926f78f5cec29d39d2dd3e803a9006e7a2b52f93917d6b19230457932c2681e4c395d752715 0039-fix-iconv-conversions-to-legacy-8bit-encodings.patch
9c71b7382cfe7a4480671b4e3bc18db79e68935ae271f0b6d43cd46d0ae87b059322592a0ca96f9e95779c57953708f1891e588e1b17d4b73f286a2d45ee1fd4 0040-fix-fchown-fallback-on-arches-without-chown-2.patch
11bde485e070cdbca2f7c1a441152f608dad1273fb8a3c3206e02e81308806e9bb9ff5a50e50a00486d4d69c65d9eda6b9a1ad4897e828241b8c07acaaf869ea 0041-towupper-towlower-fast-path-for-ascii-chars.patch
+d0e11ff77cfbe1473ae90497180fa6c8972a8acdaafdb732ce42da5762cf0f4ed5fd9a60b0bb19009ca27b5d301257ef5ad6af0a6af487a2dfea57ea881321dd 0042-fix-glob-failure-to-match-plain-to-root-directory.patch
+8719e563b48458bcadfa7e8ffad1e6ad808d99af837437ea055d4a7d684742e0e2ff6b730fe4bf63efc81a0802952cfe53394578188b6bf9fc63c5bfa20db83e 0043-catopen-set-errno-to-EOPNOTSUPP.patch
+343d4177e8059461a1df93c6517fe6a4b3ad140653ff173458062714b512d58d45050e03087e375d986552ea825cbca1f77542fc934e35dc1c51d056268029f5 0044-getdate-correctly-specify-error-number.patch
+a8bc306ca7109f3e2a81fde2ef0d9468428551eb47a4b083c17c7659dac1bca126a8330ce3cc580db79e2eb89bbc299c16878ecf17988cdc9f72ff489d2f415d 0045-handle-mremap-failure-in-realloc-of-mmap-serviced-al.patch
+c6c97ccc7b5a88a6e32ab8bb0cd35ae4689c144fd8b0f40e880061d374e5a71365066f89263d181affcd83613e2d92602a6adbf3ab2893c4dc88f667320a1f26 0046-handle-localtime-errors-in-ctime.patch
+b3e00f1d83314736d2c7b4bee59bc1055fdbc2bb4ce75b62a293c99abeb372afc1c5e73c4d878bf1d865964daf93e2e413890c60e0be6c72982c257d067c4b73 0047-set-errno-when-getpw-_r-getgr-_r-and-getspnam_r-fail.patch
+fc2c08156e755a9e178ede1642673b1f1ba06be467ff607fc3f9ea9052ddb2fa8d0ff425fd764aa7f4fc9bbd6ae0db86ad95c128e4f0da0a901980b449efa659 0048-handle-errors-from-localtime_r-in-ctime_r.patch
+053f5a09494dc117ae83ff801241fa71f1401303c53587bb01c2e7367a8149912c74dbe52373fc19f82eef9df41091e33faab5728598f99d7c9bb655701e331c 0049-fix-iconv-conversions-for-iso88592-iso885916.patch
7e4c703e57a3564cd3ee1d5334b806cbe654355179ba55d4d25361dfc555eb4a7d081d80d64fdaff8476949afd04558d278b124d1fb108080beaa5ba2f8ce2b9 1000-implement-strftime-GNU-extension-padding-specifiers-.patch
8d3a2d5315fc56fee7da9abb8b89bb38c6046c33d154c10d168fb35bfde6b0cf9f13042a3bceee34daf091bc409d699223735dcf19f382eeee1f6be34154f26f ldconfig
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c