aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-26 17:43:57 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-26 17:45:50 +0200
commit0dcb1aec32f8c0bfe43b3a544ed330251e069ae5 (patch)
tree6f97e11eda313ccb91b9eeb6c7f9103bcfb2a51a /main/nginx
parent1200346c7885ce07c900d076a052dde389ed7554 (diff)
downloadaports-0dcb1aec32f8c0bfe43b3a544ed330251e069ae5.tar.bz2
aports-0dcb1aec32f8c0bfe43b3a544ed330251e069ae5.tar.xz
main/nginx: add checkconfig to init script
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD4
-rw-r--r--main/nginx/nginx.initd7
2 files changed, 8 insertions, 3 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index b07cca0cff..e208554009 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -9,7 +9,7 @@
#
pkgname=nginx
pkgver=1.12.1
-pkgrel=2
+pkgrel=3
# Revision of nginx-tests to use for check().
_tests_hgrev=cdd44ff602db
pkgdesc="HTTP and reverse proxy server (stable version)"
@@ -274,7 +274,7 @@ fd8bce0e7d69552267b8e405b07fc9323e25e06cceb8912a2d143952447a4299756e6a9a8a40f4ea
ac7e3153ab698b4cde077f0d5d7ac0a58897927eb36cf3b58cb01268ca0296f1d589c0a5b4f889b96b5b4a57bef05b17c59be59a9d7c4d7a3d3be58f101f7f41 nginx.conf
0907f69dc2d3dc1bad3a04fb6673f741f1a8be964e22b306ef9ae2f8e736e1f5733a8884bfe54f3553fff5132a0e5336716250f54272c3fec2177d6ba16986f3 default.conf
09b110693e3f4377349ccea3c43cb8199c8579ee351eae34283299be99fdf764b0c1bddd552e13e4d671b194501618b29c822e1ad53b34101a73a63954363dbb nginx.logrotate
-1ea032cf88021ec8aa1401d284ea738364511cdb9f8c01670deb8e59aae570f5bbe17f0cbab73c0e08d6b342a621b6a9c014832168ed41f6028ecfa4211b60cf nginx.initd
+45072c8913acfa1c66431662ec32d0d5d5de79acfbbf82b613c48879b2505f336064d234da8a9ff4c7ae526bfb1c205d734df4634fa970217b161887d8f6b83f nginx.initd
558764c9be913a4f61d0e277d07bf3c272e1ce086b3fadb85b693a7e92805cd9fca4da7a8d29c96e53fc0d23b331327d3b2561ff61f19d2330e7d5d35ac7d614 ngx_devel_kit-0.3.0.tar.gz
1134d404ec9fd163d410c6ac6d8ec55515586e470aad17f1909e23c4fd35217a39639fa24cdffcf3b32733bb83c5f47508e16fb22f9d2c42e8226bda51b4ae38 ngx_cache_purge-2.4.1.tar.gz
c455bee73cebd0752449472452d15614b9587ddd199263d366484ede890c4d108eacbbeaef31adc9dc7732b56ef2bfc73c0fef3366366db03a8ec3fdc27a985c echo-nginx-module-0.60.tar.gz
diff --git a/main/nginx/nginx.initd b/main/nginx/nginx.initd
index 992d5fd5b9..c4e8bf81ac 100644
--- a/main/nginx/nginx.initd
+++ b/main/nginx/nginx.initd
@@ -1,6 +1,7 @@
#!/sbin/openrc-run
description="Nginx http and reverse proxy server"
+extra_commands="checkconfig"
extra_started_commands="reload reopen upgrade"
cfgfile=${cfgfile:-/etc/nginx/nginx.conf}
@@ -15,9 +16,13 @@ depend() {
}
start_pre() {
- ebegin
checkpath --directory --owner nginx:nginx ${pidfile%/*}
$command $command_args -t -q
+}
+
+checkconfig() {
+ ebegin "Checking ${SVCNAME} configuration"
+ start_pre
eend $?
}