aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-18 23:43:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-19 00:09:59 +0200
commit962a11002689aee3f24d7bfa90a0ecfeff4ae7ae (patch)
tree9389c8ffbaeee8cc54f1cbc7a6eb2095a9a99811 /main/nginx
parent1532b11a75cf54d5fd0ec4fb953e912e3e5daa5b (diff)
downloadaports-962a11002689aee3f24d7bfa90a0ecfeff4ae7ae.tar.bz2
aports-962a11002689aee3f24d7bfa90a0ecfeff4ae7ae.tar.xz
main/nginx: add _url variable for all modules
To be easier to get on homepage of the module, and so make @ncopa happier. :)
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index cbc522c501..ec0dcb22d8 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -14,40 +14,48 @@ license="custom"
# Modules
_devel_kit_name=ngx_devel_kit
_devel_kit_ver=0.3.0
+_devel_kit_url="https://github.com/simpl/ngx_devel_kit"
_devel_kit_dir="$srcdir/$_devel_kit_name-$_devel_kit_ver"
_devel_kit_so="ndk_http_module.so"
_http_echo_name=echo-nginx-module
_http_echo_ver=0.60
+_http_echo_url="https://github.com/openresty/echo-nginx-module"
_http_echo_dir="$srcdir/$_http_echo_name-$_http_echo_ver"
_http_fancyindex_name=ngx-fancyindex
_http_fancyindex_ver=0.4.1
+_http_fancyindex_url="https://github.com/aperezdc/ngx-fancyindex"
_http_fancyindex_dir="$srcdir/$_http_fancyindex_name-$_http_fancyindex_ver"
_http_headers_more_name=headers-more-nginx-module
_http_headers_more_ver=0.32
+_http_headers_more_url="https://github.com/openresty/headers-more-nginx-module"
_http_headers_more_dir="$srcdir/$_http_headers_more_name-$_http_headers_more_ver"
_http_headers_more_so="ngx_http_headers_more_filter_module.so"
_http_lua_name=lua-nginx-module
_http_lua_ver=0.10.7
+_http_lua_url="https://github.com/openresty/lua-nginx-module"
_http_lua_dir="$srcdir/$_http_lua_name-$_http_lua_ver"
_http_lua_depends="$pkgname-mod-devel-kit"
_http_lua_provides="$pkgname-lua" # for backward compatibility
_http_nchan_name=nchan
_http_nchan_ver=1.1.0
+_http_nchan_url="https://github.com/slact/nchan"
_http_nchan_dir="$srcdir/$_http_nchan_name-$_http_nchan_ver"
_http_nchan_so="ngx_nchan_module.so"
_http_upload_progress_name=nginx-upload-progress-module
_http_upload_progress_ver=0.9.2
+_http_upload_progress_url="https://github.com/masterzen/nginx-upload-progress-module"
_http_upload_progress_dir="$srcdir/$_http_upload_progress_name-$_http_upload_progress_ver"
_http_upload_progress_so="ngx_http_uploadprogress_module.so"
_rtmp_name=nginx-rtmp-module
_rtmp_ver=1.1.10
+_rtmp_url="https://github.com/arut/nginx-rtmp-module"
_rtmp_dir="$srcdir/$_rtmp_name-$_rtmp_ver"
_rtmp_provides="$pkgname-rtmp" # for backward compatibility
@@ -62,14 +70,14 @@ install="$pkgname.pre-install $pkgname.post-upgrade"
subpackages="$pkgname-doc $pkgname-vim::noarch"
replaces="$pkgname-common $pkgname-initscripts $pkgname-lua $pkgname-rtmp"
source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
- $_devel_kit_name-$_devel_kit_ver.tar.gz::https://github.com/simpl/$_devel_kit_name/archive/v$_devel_kit_ver.tar.gz
- $_http_echo_name-$_http_echo_ver.tar.gz::https://github.com/openresty/$_http_echo_name/archive/v$_http_echo_ver.tar.gz
- $_http_fancyindex_name-$_http_fancyindex_ver.tar.gz::https://github.com/aperezdc/$_http_fancyindex_name/archive/v$_http_fancyindex_ver.tar.gz
- $_http_headers_more_name-$_http_headers_more_ver.tar.gz::https://github.com/openresty/$_http_headers_more_name/archive/v$_http_headers_more_ver.tar.gz
- $_http_lua_name-$_http_lua_ver.tar.gz::https://github.com/openresty/$_http_lua_name/archive/v$_http_lua_ver.tar.gz
- $_http_nchan_name-$_http_nchan_ver.tar.gz::https://github.com/slact/$_http_nchan_name/archive/v$_http_nchan_ver.tar.gz
- $_http_upload_progress_name-$_http_upload_progress_ver.tar.gz::https://github.com/masterzen/$_http_upload_progress_name/archive/v$_http_upload_progress_ver.tar.gz
- $_rtmp_name-$_rtmp_ver.tar.gz::https://github.com/arut/$_rtmp_name/archive/v$_rtmp_ver.tar.gz
+ $_devel_kit_name-$_devel_kit_ver.tar.gz::$_devel_kit_url/archive/v$_devel_kit_ver.tar.gz
+ $_http_echo_name-$_http_echo_ver.tar.gz::$_http_echo_url/archive/v$_http_echo_ver.tar.gz
+ $_http_fancyindex_name-$_http_fancyindex_ver.tar.gz::$_http_fancyindex_url/archive/v$_http_fancyindex_ver.tar.gz
+ $_http_headers_more_name-$_http_headers_more_ver.tar.gz::$_http_headers_more_url/archive/v$_http_headers_more_ver.tar.gz
+ $_http_lua_name-$_http_lua_ver.tar.gz::$_http_lua_url/archive/v$_http_lua_ver.tar.gz
+ $_http_nchan_name-$_http_nchan_ver.tar.gz::$_http_nchan_url/archive/v$_http_nchan_ver.tar.gz
+ $_http_upload_progress_name-$_http_upload_progress_ver.tar.gz::$_http_upload_progress_url/archive/v$_http_upload_progress_ver.tar.gz
+ $_rtmp_name-$_rtmp_ver.tar.gz::$_rtmp_url/archive/v$_rtmp_ver.tar.gz
nginx.conf
default.conf
$pkgname.logrotate