aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-15 21:35:50 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-15 21:36:13 +0100
commitaffa8e396bcfc542aae2c8cedf19d08588dbc507 (patch)
tree9c39b1fb5043bf7a184128bcaa0fc658f720b39a /main/nginx
parenta7d9ddb1d6795f08a2003bc06f2f2f12f7858c12 (diff)
downloadaports-affa8e396bcfc542aae2c8cedf19d08588dbc507.tar.bz2
aports-affa8e396bcfc542aae2c8cedf19d08588dbc507.tar.xz
main/nginx: remove file committed by mistake
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD.new-module308
1 files changed, 0 insertions, 308 deletions
diff --git a/main/nginx/APKBUILD.new-module b/main/nginx/APKBUILD.new-module
deleted file mode 100644
index 387fac1a23..0000000000
--- a/main/nginx/APKBUILD.new-module
+++ /dev/null
@@ -1,308 +0,0 @@
-# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-# Contributor: Jeff Bilyk <jbilyk@gmail.com>
-# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-
-pkgname=nginx
-pkgver=1.12.0
-pkgrel=0
-pkgdesc="HTTP and reverse proxy server (stable version)"
-url="http://www.nginx.org/en"
-arch="all"
-license="custom"
-
-# Revision of nginx-tests to use for check().
-_tests_hgrev=cdd44ff602db
-_tests_dir="$srcdir/nginx-tests-$_tests_hgrev"
-
-# Modules
-_devel_kit_name=ngx_devel_kit
-_devel_kit_ver=0.3.0
-_devel_kit_url="https://github.com/simpl/ngx_devel_kit"
-_devel_kit_dir="$srcdir/$_devel_kit_name-$_devel_kit_ver"
-_devel_kit_so="ndk_http_module.so"
-
-_http_echo_name=echo-nginx-module
-_http_echo_ver=0.60
-_http_echo_url="https://github.com/openresty/echo-nginx-module"
-_http_echo_dir="$srcdir/$_http_echo_name-$_http_echo_ver"
-
-_http_fancyindex_name=ngx-fancyindex
-_http_fancyindex_ver=0.4.1
-_http_fancyindex_url="https://github.com/aperezdc/ngx-fancyindex"
-_http_fancyindex_dir="$srcdir/$_http_fancyindex_name-$_http_fancyindex_ver"
-
-_http_headers_more_name=headers-more-nginx-module
-_http_headers_more_ver=0.32
-_http_headers_more_url="https://github.com/openresty/headers-more-nginx-module"
-_http_headers_more_dir="$srcdir/$_http_headers_more_name-$_http_headers_more_ver"
-_http_headers_more_so="ngx_http_headers_more_filter_module.so"
-
-_http_lua_name=lua-nginx-module
-_http_lua_ver=0.10.8
-_http_lua_url="https://github.com/openresty/lua-nginx-module"
-_http_lua_dir="$srcdir/$_http_lua_name-$_http_lua_ver"
-_http_lua_depends="$pkgname-mod-devel-kit"
-_http_lua_provides="$pkgname-lua" # for backward compatibility
-
-_http_nchan_name=nchan
-_http_nchan_ver=1.1.4
-_http_nchan_url="https://github.com/slact/nchan"
-_http_nchan_dir="$srcdir/$_http_nchan_name-$_http_nchan_ver"
-_http_nchan_so="ngx_nchan_module.so"
-
-_http_set_misc_name=set-misc-nginx-module
-_http_set_misc_ver=0.31
-_http_set_misc_url="https://github.com/openresty/set-misc-nginx-module"
-_http_set_misc_dir="$srcdir/$_http_set_misc_name-$_http_set_misc_ver"
-
-_http_upload_progress_name=nginx-upload-progress-module
-_http_upload_progress_ver=0.9.2
-_http_upload_progress_url="https://github.com/masterzen/nginx-upload-progress-module"
-_http_upload_progress_dir="$srcdir/$_http_upload_progress_name-$_http_upload_progress_ver"
-_http_upload_progress_so="ngx_http_uploadprogress_module.so"
-
-_rtmp_name=nginx-rtmp-module
-_rtmp_ver=1.1.11
-_rtmp_url="https://github.com/arut/nginx-rtmp-module"
-_rtmp_dir="$srcdir/$_rtmp_name-$_rtmp_ver"
-_rtmp_provides="$pkgname-rtmp" # for backward compatibility
-
-depends=""
-makedepends="linux-headers gd-dev geoip-dev libxml2-dev libxslt-dev
- libressl-dev paxmark pcre-dev perl-dev pkgconf zlib-dev"
-checkdepends="perl perl-fcgi perl-io-socket-ssl perl-net-ssleay
- perl-protocol-websocket uwsgi-python"
-pkgusers="nginx"
-_grp_ngx="nginx"
-_grp_www="www-data"
-pkggroups="$_grp_ngx $_grp_www"
-install="$pkgname.pre-install $pkgname.post-upgrade"
-subpackages="$pkgname-doc $pkgname-vim::noarch"
-replaces="$pkgname-common $pkgname-initscripts $pkgname-lua $pkgname-rtmp"
-source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
- $pkgname-tests-$_tests_hgrev.tar.gz::http://hg.nginx.org/nginx-tests/archive/$_tests_hgrev.tar.gz
- $_devel_kit_name-$_devel_kit_ver.tar.gz::$_devel_kit_url/archive/v$_devel_kit_ver.tar.gz
- $_http_echo_name-$_http_echo_ver.tar.gz::$_http_echo_url/archive/v$_http_echo_ver.tar.gz
- $_http_echo_name~fix-nginx-1.12.patch
- $_http_fancyindex_name-$_http_fancyindex_ver.tar.gz::$_http_fancyindex_url/archive/v$_http_fancyindex_ver.tar.gz
- $_http_headers_more_name-$_http_headers_more_ver.tar.gz::$_http_headers_more_url/archive/v$_http_headers_more_ver.tar.gz
- $_http_lua_name-$_http_lua_ver.tar.gz::$_http_lua_url/archive/v$_http_lua_ver.tar.gz
- $_http_lua_name~fix-nginx-1.12.patch
- $_http_lua_name~fix-libressl.patch
- $_http_nchan_name-$_http_nchan_ver.tar.gz::$_http_nchan_url/archive/v$_http_nchan_ver.tar.gz
- $_http_set_misc_name-$_http_set_misc_ver.tar.gz::$_http_set_misc_url/archive/v$_http_set_misc_ver.tar.gz
- $_http_upload_progress_name-$_http_upload_progress_ver.tar.gz::$_http_upload_progress_url/archive/v$_http_upload_progress_ver.tar.gz
- $_rtmp_name-$_rtmp_ver.tar.gz::$_rtmp_url/archive/v$_rtmp_ver.tar.gz
- nginx.conf
- default.conf
- $pkgname.logrotate
- $pkgname.initd
- "
-builddir="$srcdir/$pkgname-$pkgver"
-
-# luajit is not available for s390x and ppc64le
-case "$CARCH" in
- ppc64le | s390x) makedepends="$makedepends lua5.1-dev";;
- *) makedepends="$makedepends luajit-dev";;
-esac
-
-_modules_dir="usr/lib/$pkgname/modules"
-_modules="
- http-geoip
- http-image-filter
- http-perl
- http-xslt-filter
- mail
- stream
- devel-kit
- http-echo
- http-fancyindex
- http-headers-more
- http-lua
- http-nchan
- http-set-misc
- http-upload-progress
- rtmp"
-for _m in $_modules; do
- subpackages="$subpackages $pkgname-mod-$_m:_module"
-done
-
-
-prepare() {
- local file; for file in $source; do
- case $file in
- *~*.patch)
- msg $file
- cd "$srcdir"/${file%%~*}-*
- patch -p 1 -i "$srcdir/$file"
- ;;
- *.patch)
- msg $file
- cd "$builddir"
- patch -p 1 -i "$srcdir/$file"
- ;;
- esac
- done
-}
-
-build() {
- cd "$builddir"
-
- export LUAJIT_LIB="$(pkgconf --variable=libdir luajit)"
- export LUAJIT_INC="$(pkgconf --variable=includedir luajit)"
- ./configure \
- --prefix=/var/lib/$pkgname \
- --sbin-path=/usr/sbin/$pkgname \
- --modules-path=/$_modules_dir \
- --conf-path=/etc/$pkgname/$pkgname.conf \
- --pid-path=/run/$pkgname/$pkgname.pid \
- --lock-path=/run/$pkgname/$pkgname.lock \
- --http-client-body-temp-path=/var/lib/$pkgname/tmp/client_body \
- --http-proxy-temp-path=/var/lib/$pkgname/tmp/proxy \
- --http-fastcgi-temp-path=/var/lib/$pkgname/tmp/fastcgi \
- --http-uwsgi-temp-path=/var/lib/$pkgname/tmp/uwsgi \
- --http-scgi-temp-path=/var/lib/$pkgname/tmp/scgi \
- --with-perl_modules_path=/usr/lib/perl5/vendor_perl \
- \
- --user=$pkgusers \
- --group=$_grp_ngx \
- --with-threads \
- --with-file-aio \
- --with-ipv6 \
- \
- --with-http_ssl_module \
- --with-http_v2_module \
- --with-http_realip_module \
- --with-http_addition_module \
- --with-http_xslt_module=dynamic \
- --with-http_image_filter_module=dynamic \
- --with-http_geoip_module=dynamic \
- --with-http_sub_module \
- --with-http_dav_module \
- --with-http_flv_module \
- --with-http_mp4_module \
- --with-http_gunzip_module \
- --with-http_gzip_static_module \
- --with-http_auth_request_module \
- --with-http_random_index_module \
- --with-http_secure_link_module \
- --with-http_slice_module \
- --with-http_stub_status_module \
- --with-http_perl_module=dynamic \
- --with-http_realip_module \
- --with-mail=dynamic \
- --with-mail_ssl_module \
- --with-stream=dynamic \
- --with-stream_ssl_module \
- \
- --add-dynamic-module="$_devel_kit_dir" \
- --add-dynamic-module="$_http_echo_dir" \
- --add-dynamic-module="$_http_fancyindex_dir" \
- --add-dynamic-module="$_http_headers_more_dir" \
- --add-dynamic-module="$_http_lua_dir" \
- --add-dynamic-module="$_http_nchan_dir" \
- --add-dynamic-module="$_http_set_misc_dir" \
- --add-dynamic-module="$_http_upload_progress_dir" \
- --add-dynamic-module="$_rtmp_dir" \
- || return 1
-
- make || return 1
-}
-
-check() {
- cd "$_tests_dir"
-
- TEST_NGINX_BINARY="$builddir/objs/nginx" prove .
-}
-
-package() {
- cd "$builddir"
-
- make DESTDIR="$pkgdir" install || return 1
-
- # Disable some PaX protections; this is needed for Lua module.
- local paxflags="-m"
- [ "$CARCH" = "x86" ] && paxflags="-msp"
- paxmark $paxflags "$pkgdir"/usr/sbin/nginx || return 1
-
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
-
- install -Dm644 objs/$pkgname.8 \
- "$pkgdir"/usr/share/man/man8/$pkgname.8 || return 1
-
- cp -r "$_devel_kit_dir"/docs \
- "$pkgdir"/usr/share/doc/$pkgname/$_devel_kit_name || return 1
- cp -r "$_http_lua_dir"/doc \
- "$pkgdir"/usr/share/doc/$pkgname/$_http_lua_name || return 1
- cp -r "$_rtmp_dir"/doc \
- "$pkgdir"/usr/share/doc/$pkgname/$_rtmp_name || return 1
-
- cd "$pkgdir"
-
- install -Dm644 "$srcdir"/nginx.conf ./etc/$pkgname/nginx.conf
- install -Dm644 "$srcdir"/default.conf ./etc/$pkgname/conf.d/default.conf
- install -Dm755 "$srcdir"/$pkgname.initd ./etc/init.d/$pkgname
- install -Dm644 "$srcdir"/$pkgname.logrotate ./etc/logrotate.d/$pkgname
-
- install -dm755 ./etc/$pkgname/modules
- install -dm750 -o $pkgusers -g $_grp_ngx ./var/lib/$pkgname
- install -dm700 -o $pkgusers -g $_grp_ngx ./var/lib/$pkgname/tmp
- install -dm755 -g $_grp_www ./var/www/localhost/htdocs
-
- install -dm755 ./var/log
- mv ./var/lib/$pkgname/logs ./var/log/$pkgname || return 1
-
- ln -sf /$_modules_dir ./var/lib/$pkgname/modules
- ln -sf /var/log/$pkgname ./var/lib/$pkgname/logs
- ln -sf /run/$pkgname ./var/lib/$pkgname/run
-
- rm -rf ./run ./etc/$pkgname/*.default
-}
-
-vim() {
- pkgdesc="$pkgdesc (vim syntax)"
- depends=
-
- mkdir -p "$subpkgdir"/usr/share/vim
- cp -r "$builddir"/contrib/vim "$subpkgdir"/usr/share/vim/vimfiles
-}
-
-_module() {
- local name="${subpkgname#$pkgname-mod-}"
- name="${name//-/_}"
- local soname="$(eval "echo \$_${name}_so")";
- soname="${soname:-"ngx_${name}_module.so"}"
-
- pkgdesc="$pkgdesc (module $name)"
- depends="$pkgname $(eval "echo \$_${name}_depends")"
- provides="$(eval "echo \$_${name}_provides")"
-
- mkdir -p "$subpkgdir"/$_modules_dir
- cd "$subpkgdir"
-
- mv "$pkgdir"/$_modules_dir/$soname ./$_modules_dir/$soname || return 1
-
- mkdir -p "$subpkgdir"/etc/nginx/modules
- echo "load_module \"modules/$soname\";" > ./etc/nginx/modules/$name.conf
-}
-
-sha512sums="e2e930b61491d91090090d4716740895fc7812e8e266c427ac2b40c5a70493150e5c81e769c6b7563baf5f0e15b32fae8f2b11fd5699e468e1cc40706defb8ee nginx-1.12.0.tar.gz
-ca8be839aef71c537d6d3a79e2894f38790834d6310c6d15ad06900c7c2d7cf71a113847ab96ef9be0fbdfff3b7808e74dea427502b275cfd6c909550f9ba9ab nginx-tests-cdd44ff602db.tar.gz
-558764c9be913a4f61d0e277d07bf3c272e1ce086b3fadb85b693a7e92805cd9fca4da7a8d29c96e53fc0d23b331327d3b2561ff61f19d2330e7d5d35ac7d614 ngx_devel_kit-0.3.0.tar.gz
-c455bee73cebd0752449472452d15614b9587ddd199263d366484ede890c4d108eacbbeaef31adc9dc7732b56ef2bfc73c0fef3366366db03a8ec3fdc27a985c echo-nginx-module-0.60.tar.gz
-401f57ed73941619cdd41061bd92fffc00730e34cc647ea3c9345225723e9c7ebd72d9d15a703cffd93b0a99d458a05fe5efa7373ae24f41b35279285b5ca0fa echo-nginx-module~fix-nginx-1.12.patch
-ce0043ad4a2b638c5d99244d6caaa65ad142cea78884084a9aeca5a9593c68dbe508c9e4dd85dc5722eb63ef386612bffc48d4b6fc1487df244fbcb7a73bffe1 ngx-fancyindex-0.4.1.tar.gz
-e42582b45c3111de3940bbeb67ce161aca2d55adcfb00c61c12256fa0e36221d38723013f36edbcf6d1b520f8dfb49d4657df8a956e66d36e68425afad382bd1 headers-more-nginx-module-0.32.tar.gz
-ad621cec178eb37109f16ebc30dbab7b1ea344ac4b523ff1e6ad62364b8cf437488a89c593ca44b446b729a1c578e3a97685851847b4b16a147ac9eca8f23a2a lua-nginx-module-0.10.8.tar.gz
-04f7d75ce15eba99be99a76d266903c17e48742ab4bf237b988bf84f00cdbf6510c3d4eee88a24620e56dc426220192df39f4736af157fdc4e4c50b4f1d794f2 lua-nginx-module~fix-nginx-1.12.patch
-fd8bce0e7d69552267b8e405b07fc9323e25e06cceb8912a2d143952447a4299756e6a9a8a40f4eabe8b00fed475fd87ee4a982f5ad7449d59783e872c682451 lua-nginx-module~fix-libressl.patch
-458bddfb27b8aa8a99a6324a600620531b2c71f035c10304868a1acb523a288ee6f90746dbe43cd8c476ed55ad01649a225a5ea73eedf3a199387fe2049c529e nchan-1.1.4.tar.gz
-c853b041cecc3521f888be3d0483c6cf23d239259ac4f5d35b10d4483b0fb06d1d22060adedcf6605b220d99f9051faf300d06989736d510b4486f943d3a675e set-misc-nginx-module-0.31.tar.gz
-c31c46344d49704389722325a041b9cd170fa290acefe92cfc572c07f711cd3039de78f28df48ca7dcb79b2e4bbe442580aaaf4d92883fd3a14bf41d66dd9d8c nginx-upload-progress-module-0.9.2.tar.gz
-e7c897265d1e93b06f7e46a653b113e24d2451e2112a7a6da415f130928437444a0346832fd9c10042397fea6120e4e44acc2bccf649ec30ca5bffbf985672e2 nginx-rtmp-module-1.1.11.tar.gz
-ac7e3153ab698b4cde077f0d5d7ac0a58897927eb36cf3b58cb01268ca0296f1d589c0a5b4f889b96b5b4a57bef05b17c59be59a9d7c4d7a3d3be58f101f7f41 nginx.conf
-0907f69dc2d3dc1bad3a04fb6673f741f1a8be964e22b306ef9ae2f8e736e1f5733a8884bfe54f3553fff5132a0e5336716250f54272c3fec2177d6ba16986f3 default.conf
-09b110693e3f4377349ccea3c43cb8199c8579ee351eae34283299be99fdf764b0c1bddd552e13e4d671b194501618b29c822e1ad53b34101a73a63954363dbb nginx.logrotate
-1ea032cf88021ec8aa1401d284ea738364511cdb9f8c01670deb8e59aae570f5bbe17f0cbab73c0e08d6b342a621b6a9c014832168ed41f6028ecfa4211b60cf nginx.initd"