aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-04-18 14:28:38 +0300
committerJakub Jirutka <jakub@jirutka.cz>2018-04-28 20:12:59 +0200
commitdaf677dacdc4524021cebc6cb437e53330e6ae67 (patch)
tree29c93c07fb2c3f7d4310575dd7648e14a585693b /main/nginx
parentd34316d4678b8e82538f82624ce4bfea3b81e79b (diff)
downloadaports-daf677dacdc4524021cebc6cb437e53330e6ae67.tar.bz2
aports-daf677dacdc4524021cebc6cb437e53330e6ae67.tar.xz
main/nginx: upgrade to 1.14.0
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index e76ef7dec3..c7533e2dd8 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -8,10 +8,10 @@
# - CVE-2017-7529
#
pkgname=nginx
-pkgver=1.12.2
-pkgrel=6
+pkgver=1.14.0
+pkgrel=0
# Revision of nginx-tests to use for check().
-_tests_hgrev=cdd44ff602db
+_tests_hgrev=d6daf03478ad
pkgdesc="HTTP and reverse proxy server (stable version)"
url="http://www.nginx.org/en"
arch="all"
@@ -79,24 +79,24 @@ _add_module "http-echo" "v0.61" "https://github.com/openresty/echo-nginx-module"
_add_module "http-fancyindex" "v0.4.2" "https://github.com/aperezdc/ngx-fancyindex"
-_add_module "http-headers-more" "v0.32" "https://github.com/openresty/headers-more-nginx-module"
+_add_module "http-headers-more" "v0.33" "https://github.com/openresty/headers-more-nginx-module"
_http_headers_more_so="ngx_http_headers_more_filter_module.so"
-_add_module "http-lua" "v0.10.10" "https://github.com/openresty/lua-nginx-module"
+_add_module "http-lua" "v0.10.12" "https://github.com/openresty/lua-nginx-module"
_http_lua_depends="$pkgname-mod-devel-kit"
_http_lua_provides="$pkgname-lua" # for backward compatibility
_add_module "http-lua-upstream" "v0.07" "https://github.com/openresty/lua-upstream-nginx-module"
_http_lua_upstream_depends="$pkgname-mod-http-lua"
-_add_module "http-nchan" "v1.1.7" "https://github.com/slact/nchan"
+_add_module "http-nchan" "v1.1.14" "https://github.com/slact/nchan"
_http_nchan_so="ngx_nchan_module.so"
_add_module "http-shibboleth" "v2.0.1" "https://github.com/nginx-shib/nginx-http-shibboleth"
-_add_module "http-redis2" "v0.14" "https://github.com/openresty/redis2-nginx-module"
+_add_module "http-redis2" "v0.15" "https://github.com/openresty/redis2-nginx-module"
-_add_module "http-set-misc" "v0.31" "https://github.com/openresty/set-misc-nginx-module"
+_add_module "http-set-misc" "v0.32" "https://github.com/openresty/set-misc-nginx-module"
_http_set_misc_depends="$pkgname-mod-devel-kit"
_add_module "http-upload-progress" "v0.9.2" "https://github.com/masterzen/nginx-upload-progress-module"
@@ -104,7 +104,7 @@ _http_upload_progress_so="ngx_http_uploadprogress_module.so"
_add_module "http-upstream-fair" "0.1.3" "https://github.com/itoffshore/nginx-upstream-fair"
-_add_module "rtmp" "v1.2.0" "https://github.com/arut/nginx-rtmp-module"
+_add_module "rtmp" "v1.2.1" "https://github.com/arut/nginx-rtmp-module"
_rtmp_provides="$pkgname-rtmp" # for backward compatibility
_add_module "http-vod" "1.22" "https://github.com/kaltura/nginx-vod-module"
@@ -127,6 +127,7 @@ prepare() {
# This test requires superuser privileges and CAP_NET_ADMIN.
rm "$srcdir"/nginx-tests-*/proxy_bind_transparent.t
+ rm "$srcdir"/nginx-tests-*/proxy_bind_transparent_capability.t
}
build() {
@@ -264,8 +265,8 @@ _module() {
echo "load_module \"modules/$soname\";" > ./etc/nginx/modules/$name.conf
}
-sha512sums="3faa2043e237a7e1d15cc5661ac9d002a965220a78c25a863be9f19e01007347e53f776b61c229f6bd3d916cc1ccf92de260811f7b8092ec1b747fba7c0061f7 nginx-1.12.2.tar.gz
-ca8be839aef71c537d6d3a79e2894f38790834d6310c6d15ad06900c7c2d7cf71a113847ab96ef9be0fbdfff3b7808e74dea427502b275cfd6c909550f9ba9ab nginx-tests-cdd44ff602db.tar.gz
+sha512sums="40f086c9f741727e6f55802b6c3a66f081f7c49c38646dc1491aa3e3c35bae12b65ea6594386609fc849bcd99a60d7cd8ecb3f8d519e0e9ab8db01d653e930e9 nginx-1.14.0.tar.gz
+775f8fcc55e0e670f7b509974cc9e9cfb56e4bd2a88d1c7716c96b63ad87c14fd6d07f293545639972e798fb20f81414ef6483451d00ae5a4eaa262ccf2cbc98 nginx-tests-d6daf03478ad.tar.gz
ac7e3153ab698b4cde077f0d5d7ac0a58897927eb36cf3b58cb01268ca0296f1d589c0a5b4f889b96b5b4a57bef05b17c59be59a9d7c4d7a3d3be58f101f7f41 nginx.conf
0907f69dc2d3dc1bad3a04fb6673f741f1a8be964e22b306ef9ae2f8e736e1f5733a8884bfe54f3553fff5132a0e5336716250f54272c3fec2177d6ba16986f3 default.conf
09b110693e3f4377349ccea3c43cb8199c8579ee351eae34283299be99fdf764b0c1bddd552e13e4d671b194501618b29c822e1ad53b34101a73a63954363dbb nginx.logrotate
@@ -274,14 +275,14 @@ eb183860cd511361346e4079c1fcf470985e1c3b2a034a57f8b2a92ba851fed99256261f9b779770
1c2e6f5026becbd7bdf9feb920f10c19c6c5487600008161b045e9d6b5ea0269af68a2869e57b528bc921d549c541e6dbb02eb2ef26416a22d5d5a7f3ffc552b ngx_cache_purge-2.4.2.tar.gz
c90b81a4e85a8e9beeb5ff591dc91adb25fa4e0b6cb47086b577e5fa36db2368442dd011187675e358781956c364b949bc4d920ca2b534481b21c9987d2a9a3b echo-nginx-module-0.61.tar.gz
aee121e4d25872f0eee6c8150c8c732767ab24c61dc4f6e3f86bd6edc53ad715f3c23045362954a1ad2086ff1002bca821b2e9a53b58b077cbda91a95077ef76 ngx-fancyindex-0.4.2.tar.gz
-e42582b45c3111de3940bbeb67ce161aca2d55adcfb00c61c12256fa0e36221d38723013f36edbcf6d1b520f8dfb49d4657df8a956e66d36e68425afad382bd1 headers-more-nginx-module-0.32.tar.gz
-3440e3fe714407f0ff61e0da207669655b443f7b70ef8a91693ea05ed96d8fde349d9c8ea30d5ff53ea3f8e4a5c7d0a2834e136c340b1b1365d62006339a1e4d lua-nginx-module-0.10.10.tar.gz
+13165b1b8d4be281b8bd2404fa48d456013d560bace094c81da08a35dc6a4f025a809a3ae3a42be6bbf67abbcbe41e0730aba06f905220f3baeb01e1192a7d37 headers-more-nginx-module-0.33.tar.gz
+f2a0fb30844c5c406a0e0e6cc4ef2ebb9a1ca5c157a93e76ce142ae7b776d98cde32e6150ea76bed6c2ed82a2ca21642c3d673a0249c44126266df69bcc95fb8 lua-nginx-module-0.10.12.tar.gz
72887c4490854b099cb26bb3f840073a36b0d812bde4486f04dc1be182ca74f0d1e3fd709e77c240c2dcf37665f74cf04e188ea9efe8e127c6789b27b487d0cd lua-upstream-nginx-module-0.07.tar.gz
-1e9b029912ef6e89dba8e3aed57d50848b52fbeb1077d965ca39aea14c2b34c11092ee53db47fb1df9e5adaf466f849c5a33cade881fddb420c1a036bc659d4b nchan-1.1.7.tar.gz
+f07f39923b89e67eb0dd98938ce3ecd991d13df456ec9937323550a6d3c25a99f22b829f9f779c9104abe5af89487636d46ab73ff7c08de63749fc65049218ec nchan-1.1.14.tar.gz
1730845ea2e52be8c2f6cfceb2894304c5a07959a96940bb1617ee0e7cf81d22283304f411d9a219ddb71e4d9a66012bba0f6f5574d101aeb3c406f26c5d6a4e nginx-http-shibboleth-2.0.1.tar.gz
-a22cfab85f5a15cf4b778749227caee559982dbe7711e1c5698456b3821943ec66b7a980ed56612b7f2ae70d22832123be24e50a402c659c6f3eb1d98d60b4cd redis2-nginx-module-0.14.tar.gz
-c853b041cecc3521f888be3d0483c6cf23d239259ac4f5d35b10d4483b0fb06d1d22060adedcf6605b220d99f9051faf300d06989736d510b4486f943d3a675e set-misc-nginx-module-0.31.tar.gz
+d6ca250db8de93edbd7875afca35e73cecdaf82132d1a7ee933cf94c6b8afa8e629e9e647a9321f2bc1fbb92137ec0d32dcd89b82ac5fae31e342537fb7e0431 redis2-nginx-module-0.15.tar.gz
+5590526f60c99630f99a49bfa9e3455baee6d58cd2a1419eab1367a838dafb87a50f5e2607aa8ac557b90dbf633dcf61069c997b3526cddc8f2fc45820a7bc3b set-misc-nginx-module-0.32.tar.gz
c31c46344d49704389722325a041b9cd170fa290acefe92cfc572c07f711cd3039de78f28df48ca7dcb79b2e4bbe442580aaaf4d92883fd3a14bf41d66dd9d8c nginx-upload-progress-module-0.9.2.tar.gz
8adb7453c27748f4e685e3352e9b318b408da818754dc5b6244e908423941a8ba337561104f6e481f2553cbc0e334dcea73b57f8e810a9d6e974bb69ff8859e5 nginx-upstream-fair-0.1.3.tar.gz
-8965d9bee91a46375516ccd012d1c43cd23f15c0630d11ed01472b9a84504574b476f22c5584f43c972a8f923e9ae025b9b60c64aace0ed159c7279bcbd376c8 nginx-rtmp-module-1.2.0.tar.gz
+4a0af5e9afa4deb0b53de8de7ddb2cfa6430d372e1ef9e421f01b509548bd134d427345442ac1ce667338cc2a1484dc2ab732e316e878ac7d3537dc527d5f922 nginx-rtmp-module-1.2.1.tar.gz
ee1d55c406ff7c0943ec3c6069d087a238021b5be7839c9fa7e61bd8d324dc1a831d9ee1ec9ee6f6b7b0e0514cd87ff3690ac4183525a0980537d46175c430ad nginx-vod-module-1.22.tar.gz"