aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-25 17:05:21 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-25 17:06:33 +0200
commiteed57f64a942c45a8e0b73760e7505304b9a434f (patch)
tree06f3676f13050c52ccf7eefdbb7720421deac069 /main/nginx
parent9f6224331043d4d6eebb9e282b9e874d8f5ca507 (diff)
downloadaports-eed57f64a942c45a8e0b73760e7505304b9a434f.tar.bz2
aports-eed57f64a942c45a8e0b73760e7505304b9a434f.tar.xz
main/nginx: print info message in pre-upgrade script
It may take a longer time to move the files, so user should be informed what is going on.
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD2
-rw-r--r--main/nginx/nginx.pre-upgrade2
2 files changed, 3 insertions, 1 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index ece2d18d28..ab3f29f2b3 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -9,7 +9,7 @@
#
pkgname=nginx
pkgver=1.12.2
-pkgrel=1
+pkgrel=2
# Revision of nginx-tests to use for check().
_tests_hgrev=cdd44ff602db
pkgdesc="HTTP and reverse proxy server (stable version)"
diff --git a/main/nginx/nginx.pre-upgrade b/main/nginx/nginx.pre-upgrade
index 72055c757a..67f05dda1c 100644
--- a/main/nginx/nginx.pre-upgrade
+++ b/main/nginx/nginx.pre-upgrade
@@ -10,6 +10,8 @@ if [ "$(apk version -t "$ver_old" '1.12.0-r1')" = '<' ]; then
# Create a new temp directory, move data from the old one to the new
# one and delete the old one.
if [ -d "$tmp_old" ]; then
+ echo "* Moving data from $tmp_old to $tmp_new..." >&2
+
[ -d "$tmp_new" ] \
|| install -d -m 700 -o nginx -g nginx "$tmp_new"
rmdir "$tmp_old" 2>/dev/null \