aboutsummaryrefslogtreecommitdiffstats
path: root/main/openssl
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-02-22 17:07:15 -0500
committerTimo Teräs <timo.teras@iki.fi>2017-02-23 06:24:16 +0000
commit80652d604ebaac0d1f92923fc083387652e91cc5 (patch)
tree6e5d3d5016282c8aa8fda0ffcede39360334b780 /main/openssl
parente60549f23a60fec682c7b41690a97bb5335decc7 (diff)
downloadaports-80652d604ebaac0d1f92923fc083387652e91cc5.tar.bz2
aports-80652d604ebaac0d1f92923fc083387652e91cc5.tar.xz
main/openssl: add s390x support
Diffstat (limited to 'main/openssl')
-rw-r--r--main/openssl/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index 49ffa89b2d..57e13d8954 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -70,6 +70,7 @@ build() {
ppc64le) _target="linux-ppc64le" ;;
x86) _target="linux-elf" ;;
x86_64) _target="linux-x86_64"; _optflags="enable-ec_nistp_64_gcc_128" ;;
+ s390x) _target="linux64-s390x";;
*) msg "Unable to determine architecture from (CARCH=$CARCH)" ; return 1 ;;
esac