aboutsummaryrefslogtreecommitdiffstats
path: root/main/p7zip
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-04-01 13:53:15 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-04-01 13:53:15 +0200
commita78fcf988b9c45b679a4e4c13b0fb77cb1e29ca5 (patch)
tree9406e898f264a9812e50d786b991eda485e9bfd4 /main/p7zip
parent695e8beb15a76f2a02d8198fdfc376fd5a5d3c42 (diff)
downloadaports-a78fcf988b9c45b679a4e4c13b0fb77cb1e29ca5.tar.bz2
aports-a78fcf988b9c45b679a4e4c13b0fb77cb1e29ca5.tar.xz
main/p7zip: upgrade to 15.14.1
Diffstat (limited to 'main/p7zip')
-rw-r--r--main/p7zip/APKBUILD40
1 files changed, 30 insertions, 10 deletions
diff --git a/main/p7zip/APKBUILD b/main/p7zip/APKBUILD
index a011172f75..1b43b2f825 100644
--- a/main/p7zip/APKBUILD
+++ b/main/p7zip/APKBUILD
@@ -1,19 +1,34 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=p7zip
-pkgver=15.09
+pkgver=15.14.1
pkgrel=0
pkgdesc="A command-line port of the 7zip compression utility"
url="http://p7zip.sourceforge.net"
arch="all"
license="LGPL2+"
subpackages="$pkgname-doc"
-depends=
-makedepends="bash"
-install=
+depends=""
+makedepends="bash yasm nasm"
+install=""
source="http://downloads.sourceforge.net/sourceforge/$pkgname/${pkgname}_${pkgver}_src_all.tar.bz2"
_builddir="$srcdir"/${pkgname}_${pkgver}
+prepare() {
+ local makefile="makefile.linux_any_cpu_gcc_4.X"
+ case "$CARCH" in
+ x86) makefile="makefile.linux_x86_asm_gcc_4.X" ;;
+ x86_64) makefile="makefile.linux_amd64_asm" ;;
+ esac
+
+ cd "$_builddir"
+ ln -sf $makefile makefile.machine || return 1
+
+ sed -e "s,g++,${CXX:-g++}," -i makefile.machine
+ sed -e "s,gcc,${CC:-gcc}," -i makefile.machine
+}
+
build() {
cd "$_builddir"
make all3 OPTFLAGS="${CXXFLAGS}" || return 1
@@ -21,11 +36,16 @@ build() {
package() {
cd "$_builddir"
- ./install.sh /usr/bin /usr/libexec/$pkgname /usr/share/man /usr/share/doc "$pkgdir"
- cp contrib/gzip-like_CLI_wrapper_for_7z/p7zip "$pkgdir"/usr/bin/
- cp contrib/gzip-like_CLI_wrapper_for_7z/man1/* "$pkgdir"/usr/share/man/man1/
+ make install DEST_DIR="$pkgdir" DEST_HOME="/usr" \
+ DEST_MAN="/usr/share/man" \
+ DEST_SHARE_DOC="/usr/share/doc/$pkgname" || return 1
+
+ install -Dm755 contrib/gzip-like_CLI_wrapper_for_7z/$pkgname \
+ "$pkgdir"/usr/bin/$pkgname || return 1
+ install -Dm644 contrib/gzip-like_CLI_wrapper_for_7z/man1/$pkgname.1 \
+ "$pkgdir"/usr/share/man/man1/$pkgname.1 || return 1
}
-md5sums="ab69f4f13ba0ec57eca2cf4c9edd9678 p7zip_15.09_src_all.tar.bz2"
-sha256sums="8783acf747e210e00150f7311cc06c4cd8ecf7b0c27b4adf2194284cc49b4d6f p7zip_15.09_src_all.tar.bz2"
-sha512sums="4f020b13632ef7a85aa8a98586b59bef2dde3c1cbebdbd17e01f1d09b2e13a56ecfe82546d7efc677c45df67456a71cfdb67826b53ebea4c0fb4878f20c2f6dd p7zip_15.09_src_all.tar.bz2"
+md5sums="92cca093312b5a71a7be7dc7d1d32509 p7zip_15.14.1_src_all.tar.bz2"
+sha256sums="699db4da3621904113e040703220abb1148dfef477b55305e2f14a4f1f8f25d4 p7zip_15.14.1_src_all.tar.bz2"
+sha512sums="30d0ef47bd6938cdd5d9d80ec6e7aed972655686a43adb0ae34bb9856ec7cd5a68a05c580352021055cefd6eeceb134ff6402f93686ce46e57f9757798e76abd p7zip_15.14.1_src_all.tar.bz2"