aboutsummaryrefslogtreecommitdiffstats
path: root/main/pango
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-08-13 10:23:27 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-08-13 10:23:27 +0200
commit1082d473cc01f407e5e78bf7de72f8a5a5c35a30 (patch)
treeefd989e37d1e9ee262f2aa0e2fc3c5c76c0dc2a4 /main/pango
parentd1a75ce8912a8cd0289ac075fd44ae462abcfd6d (diff)
downloadaports-1082d473cc01f407e5e78bf7de72f8a5a5c35a30.tar.bz2
aports-1082d473cc01f407e5e78bf7de72f8a5a5c35a30.tar.xz
main/pango: fix generation of pango modules.cache
ref #5421
Diffstat (limited to 'main/pango')
-rw-r--r--main/pango/APKBUILD5
-rw-r--r--main/pango/pango.post-install2
-rw-r--r--main/pango/pango.pre-deinstall4
-rw-r--r--main/pango/pango.trigger3
4 files changed, 7 insertions, 7 deletions
diff --git a/main/pango/APKBUILD b/main/pango/APKBUILD
index e22fa68c9e..8079158052 100644
--- a/main/pango/APKBUILD
+++ b/main/pango/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pango
pkgver=1.36.8
-pkgrel=0
+pkgrel=1
pkgdesc="A library for layout and rendering of text"
url="http://www.pango.org/"
arch="all"
@@ -10,7 +10,8 @@ subpackages="$pkgname-dev $pkgname-doc"
depends=
depends_dev="glib-dev freetype-dev fontconfig-dev libxft-dev harfbuzz-dev"
makedepends="$depends_dev cairo-dev expat-dev gobject-introspection-dev"
-install="pango.post-install $pkgname.pre-deinstall"
+install="$pkgname.pre-deinstall"
+triggers="$pkgname.trigger=/usr/lib/pango/*/modules"
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
build () {
diff --git a/main/pango/pango.post-install b/main/pango/pango.post-install
deleted file mode 100644
index 9d7dad4ec0..0000000000
--- a/main/pango/pango.post-install
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-/usr/bin/pango-querymodules > /etc/pango/pango.modules
diff --git a/main/pango/pango.pre-deinstall b/main/pango/pango.pre-deinstall
index 9a59403fc5..bcffa7c145 100644
--- a/main/pango/pango.pre-deinstall
+++ b/main/pango/pango.pre-deinstall
@@ -1,5 +1,3 @@
#!/bin/sh
-if [ -e /etc/pango/pango.modules ]; then
- rm -f /etc/pango/pango.modules
-fi
+exec /bin/rm -f /etc/pango/pango.modules /usr/lib/pango/*/modules.cache
diff --git a/main/pango/pango.trigger b/main/pango/pango.trigger
new file mode 100644
index 0000000000..720a0b9a73
--- /dev/null
+++ b/main/pango/pango.trigger
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/bin/pango-querymodules > ${1}.cache